Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was using MiKTeX 2.9 (x64) on my Win 7 machine for some time with TeXnicCenter. Now I tried to install LyX on the same PC. The problem I get is Lyx does find neither latex.exe nor sees all the other files in \bin folder of MiKTeX. I read Lyx had problem with x64 bit MiKTeX, so I removed every "MiKTeX 2.9 x64" in Windows path and in "Lyx->Tools->Preferences-PATH prefix" and just leave 32-bit version in it. When I do: "latex.exe" in cmd, I get the correct version:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9)

I also tried to reconfigure LyX (Tools->Reconfigure), but always get this error:

The system reconfiguration has failed.
Default textclass is used but LyX may not be able to work properly.
Please reconfigure again if needed.

I also tried to reinstall LyX-2-0.5-Installer-3.exe and tried even with LyX-2-0.5-Bundle-3.exe. Both installations seems to finish with no error. I also tried to log off and log on, recheck all the PATHs, but nothing seems to help.

When I try to export (File->Export...) I see a popup window with no output formats. I also tried to add a new environment variable "miktexdir", but that did not do any change whatsoever. Also tried to run as Administrator, no help.

What am I doing wrong, what is the solution?

share
    
Oh yeah, and this reconfiguration error is always seen on program lunch, but I can not do anything about it (no "reconfiguration" is possible). –  TomiL Feb 25 '13 at 20:52
2  
I don't understand much at all why things are so tricky in Windows (I use Ubuntu), but here is a recent bug that might be related: lyx.org/trac/ticket/8268. I think that Uwe is working hard trying to fix such issues so hopefully these will go away. –  scottkosty Feb 26 '13 at 4:14
    
I cannot help with LyX, but one thing, you did, and should never had done, is removing MiKTeX from the system path without uninstalling it. Make a clean uninstall and then an installation of the 32-bit MiKTeX version. –  Speravir Feb 27 '13 at 1:50
comments disabled on deleted / locked posts

migration rejected from stackoverflow.com Jan 24 at 4:49

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as unclear what you're asking by Speravir, barbara beeton, Werner, cmhughes, Jesse Jan 24 at 4:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.