Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a beamer .tex file which I know works perfectly on TexShop. However, when I texify the same document on WinEdt 6.0, the document does not display properly. No images appear, and anytime I try to scroll down the document, I get a message saying:

MiKTeX Problem Report
Some PostScript specials could not be rendered.
Data:
Error: /undefined in H.S
Operand stack:
   --nostringval--   PermitFileReading   --nostringval--   PermitFileWriting   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1914   1   3   %oparray_pop   1913   1   3   %oparray_pop   1897   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1166/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:95/300(L)--   --dict:17/200(L)--
Current allocation mode is local
MiKTeX GPL Ghostscript  9.00: Unrecoverable error, exit code 1

What can I do to prevent this error and display everything properly?

Update

This is how I setup my code:

\documentclass[10pt]{beamer}
  \usetheme{Warsaw}
  \setbeamertemplate{navigation symbols}{}

\setbeamercolor*{palette secondary}{use=structure,fg=white,bg=structure.fg!60!blue}
\setbeamercolor*{palette tertiary}{use=structure,fg=white,bg=orange!85!blue}

\def\colorize<#1>{%
 \temporal<#1>{\color{black!20}}{\color{black}}{\color{black!20}}}

\usepackage{palatino}
\usepackage{graphicx}
\usepackage{amsmath}
\usepackage{amssymb}

\title{My Groundbreaking Presentation}
\author{You Know Who}
\date{\today}

% note: do NOT include a \maketitle line; also note that this title
% material goes BEFORE the \begin{document}

% have this if you'd like a recurring outline
\AtBeginSection[]  % "Beamer, do the following at the start of every section"
{
\begin{frame}<beamer>
\tableofcontents[currentsection]  % show TOC and highlight current section
\end{frame}
}

\begin{document}

\begin{frame}
\titlepage
\end{frame}

\begin{frame}
\frametitle{First Slide}
\begin{figure}[h!]
    \includegraphics[width=3in]{picture.eps}
\end{figure}
\end{frame}

%etc...

\end{document}
share|improve this question
    
Did you check using texify --tex-option=--src foo.tex as mentioned in texify miktex documentation as --src option passes --src-specials to the TeX compiler. –  texenthusiast Feb 28 '13 at 3:28
    
I'm running WinEdt on windows, so I'm not sure how/where to set this option... –  Paul Feb 28 '13 at 6:42
    
can you run from the Command window texify --tex-option=--src your-filename.tex to ensure if it is problem. Later you can follow winedt doc and winedt configure to set it up. I hope you have Ghostscript installed. –  texenthusiast Feb 28 '13 at 6:50
    
@texenthusiast: The error message is from the miktex ghostscript: So obviously a ghostscript is installed. Paul: You should make a minimal example that demonstrates the problem so that other can test it. –  Ulrike Fischer Feb 28 '13 at 7:35
    
minimal working example (MWE) means starting with \documentclass{...} and ending with \end{document}. It will help someone here to assist you. –  texenthusiast Feb 28 '13 at 9:12

2 Answers 2

I suppose that, when you say ''anytime I try to scroll down the document'' you mean you are trying to visualize it in Yap.

I've had the same problem in some .dvi documents of mine and I've solved changing the Render Method to Dvips.

To do this in Yap, go to View -> Render Method and change it from Pk to Dvips.

If you want to change it globally, go to View -> Options -> Display -> Default Render Method and do the same as above.

share|improve this answer

Few hours ago, I was trying to upload a paper and it kept rejecting the .dvi because of this rendering problem. It is true that using dvips as rendering method works well. However, if you'd like to upload the .DVI to publishing sites, say IEEEXPLORE, it won't allow it.enter image description here I use Lyx, and I got around this problem by removing the Hyperref Support, as per the Attachment. If you use Lyx, go to: Document -> Setting -> PDF Properties -> Uncheck the "Use Hyperref Support". If you are using other type, look for hyperref in the source code and remove the support.

share|improve this answer
    
Welcome to TeX.SX! I'm sorry, but I don't see any relation between a rendering problem of images with hyper links. Publishing websites, EDAS for example, usually don't want files with hyper links and that you can solve as you did or simply by not loading hyperref in the document. However, this issue would have happened even with no images in the document provided that the document has some cross reference links, say equations or bibliograpy. –  Claudio Fiandrino 2 days ago
    
This posting isn't an answer to the question, "Problems rendering BeamerTex Postscript specials in WinEdt 6.0". –  Mico 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.