Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I need to cite a paper with multiple authors:

@article{DBLP:journals/tit/HammonsKCSS94,  
  author    = {A. Roger Jr. Hammons  and
               P. Vijay Kumar and
               A. Robert Calderbank and
               Neil J. A. Sloane and
               Patrick Sol{\'e}},  
  title     = {The Z$_{\mbox{4}}$-linearity of Kerdock, Preparata, Goethals,
               and related codes},  
  journal   = {IEEE Transactions on Information Theory},  
  volume    = {40},  
  number    = {2},  
  year      = {1994},  
  pages     = {301-319},  
  ee        = {http://dx.doi.org/10.1109/18.312154},  
  bibsource = {DBLP, http://dblp.uni-trier.de}  
}

But when I made the citation it appears as [HKC+94] and I want to be [HKCSS94]. can anyone help me?

share|improve this question
    
Which bibliography style, and which document class, do you use? Separately, do use a citation management package such as natbib? –  Mico Mar 2 '13 at 0:06
    
I am new using latex, i use report as document class,alpha as bibliography style and i dont use natbib –  Dimitri Mar 2 '13 at 0:08
1  
Thanks. The appearance of the entries in the References section is determined by the bibliography style -- the argument of the command \bibliographystyle. To have a chance to help you, we thus need to know which bibliography style you employ. –  Mico Mar 2 '13 at 0:11
2  
Without switching to biblatex it isn't possible. –  Marco Daniel Mar 2 '13 at 9:09
1  
@Dimitri: I provided an answer. –  Marco Daniel Mar 3 '13 at 9:35
show 8 more comments

1 Answer 1

up vote 4 down vote accepted

As written in the comments, without using biblatex it isn't possible. By using the package biblatex you have the options minalphanames/maxalphanames. The option maxalphanames requires a number and it represents the number of authors which will be counted for the label of the style alphabetic. In your case it should be 5.

Here a MWE with the correct compilation order using arara

% arara: pdflatex
% arara: biber
% arara: pdflatex
% arara: pdflatex
\listfiles
\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@article{DBLP:journals/tit/HammonsKCSS94,  
  author    = {A. Roger Jr. Hammons  and
               P. Vijay Kumar and
               A. Robert Calderbank and
               Neil J. A. Sloane and
               Patrick Sol{\'e}},  
  title     = {The Z$_{\mbox{4}}$-linearity of Kerdock, Preparata, Goethals,
               and related codes},  
  journal   = {IEEE Transactions on Information Theory},  
  volume    = {40},  
  number    = {2},  
  year      = {1994},  
  pages     = {301-319},  
  ee        = {http://dx.doi.org/10.1109/18.312154},  
  bibsource = {DBLP, http://dblp.uni-trier.de}  
}
}
\end{filecontents*}


\documentclass[12pt]{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[style=alphabetic,maxnames=99,maxalphanames=5]{biblatex}
\addbibresource{\jobname.bib}


\begin{document}
\verb+\cite{DBLP:journals/tit/HammonsKCSS94}+\cite{DBLP:journals/tit/HammonsKCSS94}
\printbibliography
\end{document}

enter image description here

share|improve this answer
    
Thanks for the answer, i already try with biblatex, but when i do, the references don´t appear...i don´t know why, can you give any idea? –  Dimitri Mar 3 '13 at 18:11
    
Did you compile with pdflatex+biber+pdflatex? Do you get any errors? –  Marco Daniel Mar 3 '13 at 18:40
    
I fix it, i think that was a problem with the compilation, but now is ok. Thanks again for the answer, that really help me, and besides you were the only one who really try to help me with my question –  Dimitri Mar 3 '13 at 18:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.