Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have some troubles with citations and biber. I'm citing a paper several times and point to different sections in that paper. But sometimes the citation is not shown in the pdf. I can't comprehend when they are not shown. In one section they are shown properly, and in the other section simply a space appears.

First I use

\cite{Shani2011}

and the second time I use the same (copy and paste)

\cite{Shani2011}

Inside the Bib reference, the paper is also shown properly. I got no errors in my console, just a few Overfull \hbox... and !h float specifier changed to !ht warnings, and one No backend specified, using Biber backend. I don't know why this biber warning occurs, my command to compile in texmaker is (% references the current document name):

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|
"/usr/texbin/biber" %|
"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|
"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|
open %.pdf

Does anyone know where I can start to debug this?

==========================================

EDIT

Ok, here is a minimum example:

\documentclass[12pt,a4paper]{article}
\usepackage[english,ngerman]{babel}
\usepackage[authordate]{biblatex-chicago} 

\bibliography{Bibliography2}

\begin{document}
    \cite{Shani2011} blabla. \cite{Shani2011} blabla
\end{document}

This produces

Shani und Gunawardana 2011 blabla.  blabla

The second citation doesn't gets printed into the pdf. But I found out, if I cite between the two Shani2011 another paper, it works. This

\begin{document}
    \cite{Shani2011} blabla. \cite{Shani2009} blabla \cite{Shani2011} blabla
\end{document} 

produces this

Shani und Gunawardana 2011 blabla. Shani 2009 blabla Shani und Gun- awardana 2011 blabla

So I don't know why this doesn't work. Any ideas?

EDIT

Here is the Bibliography2.bib:

@article{Shani2011,
author = {Shani, Guy and Gunawardana, Asela},
title = {{Evaluating recommendation systems}},
year = {2011}
}

@article{Shani2009,
author = {Shani},
title = {{Evaluating recommendation systems}},
year = {2011}
}

EDIT

Here is the content of the Masterthsis.blg:

[1] Config.pm:361> INFO - This is Biber 1.5
[302] Config.pm:364> INFO - Logfile is 'Masterthesis.blg'
[1209] biber-darwin:193> INFO - === Tue Mar  5, 2013, 10:19:55
[1210] Biber.pm:327> INFO - Reading 'Masterthesis.bcf'
[1426] Biber.pm:619> INFO - Found 1 citekeys in bib section 0
[1841] Biber.pm:2976> INFO - Processing section 0
[2305] Biber.pm:3086> INFO - Looking for bibtex format file 'Bibliography2.bib' for section 0
[2449] bibtex.pm:764> INFO - Found BibTeX data source 'Bibliography2.bib'
[4823] Biber.pm:2860> INFO - Overriding locale 'en_US.UTF-8' default tailoring 'level = 4' with 'level = 2'
[4823] Biber.pm:2860> INFO - Overriding locale 'en_US.UTF-8' default tailoring 'variable = shifted' with 'variable = non-ignorable'
[4823] Biber.pm:2866> INFO - Sorting 'entry' list 'nyt' keys
[4824] Biber.pm:2870> INFO - No sort tailoring available for locale 'en_US.UTF-8'
[5115] bbl.pm:462> INFO - Writing 'Masterthesis.bbl' with encoding 'ascii'
[5116] bbl.pm:535> INFO - Output to Masterthesis.bbl
share|improve this question

closed as too localized by egreg, lockstep, Martin Schröder, mafp, diabonas Mar 5 '13 at 13:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Please provide us with a minimal working example (MWE). Take a look at minimalbeispiel.de/mini-en.html if you are in doubt. –  aagaard Mar 2 '13 at 16:36
1  
The "Biber backend" warning is normal if you don't specify a backend= argument when loading biblatex. It's there since version 2.0 because before that, bibtex was the default backend. You can ignore it or just add backend=biber as an option when you load biblatex. –  PLK Mar 2 '13 at 22:11
    
Thx for your comments, I added a minimal working example. Hope this helps. –  23tux Mar 4 '13 at 18:59
2  
I have no problem with your example - it shows both citations. I suspect it's something to do with an outdated biblatex-chicago style (I suspect it's a style issue anyway - not biber related). –  PLK Mar 5 '13 at 11:00
1  
and now i found the solution to the question! according to the biblatex-chicago documentation tug.org/texlive//Contents/live/texmf-dist/doc/latex/… the option noibid disables this behaviour and all citations are fully displayed. use it like this: \usepackage[noibid]{biblatex-chicago} Please reopen the question so i can post this as answer. –  Dominik Apr 13 '13 at 8:13

1 Answer 1

up vote 1 down vote accepted

I figured it out, 'cause @PLK pointed me to the right direction. It seems that an outdated biblatex-chicago package caused the problem. I thought I updated everything to the latest versions, but my package manager on OS X, Tex Live Utility, just updates partial. So I had to re-run the update process a several times (and Tex Live found after every update new versions), now it's fixed. May this helps somebody else.

share|improve this answer
    
i've updated tex-live 2012 to the latest version but i still have that problem. what version of biblatex-chicago do you have? –  Dominik Apr 10 '13 at 10:09
    
0.9.9b is my biblatex-chicago version –  23tux Apr 10 '13 at 14:30
    
the correct solution can be found in the comments of the question –  Dominik Apr 13 '13 at 8:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.