TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have used subfigures to layout my figures in the way I would like, but I would like them to have captions as if they were standard figures. IE, Figure 1, Figure 2... Is there a way of doing this?

EDIT: Here is how I am using subfigures.

\begin{center} \subfigure[Figure 1]{\includegraphics[width=\figwidth\textwidth]{1.png}}
share|improve this question
Can you please make an example of how you're doing it? – egreg Mar 6 '13 at 0:39
Please be a bit more specific about precisely how you'd like to lay out your figures. E.g., do you want them to be side by side? Are they roughly equally wide? – Mico Mar 6 '13 at 0:40
I have added one. The first subfigure is captioned as "(a) Figure 1". I would like to remove the "(a)". – superbriggs Mar 6 '13 at 0:42
I am happy with how my code lays out the subfigures. – superbriggs Mar 6 '13 at 0:43
It might make more sense to avoid subfigures and just use minipages with \caption instead... – cmhughes Mar 6 '13 at 1:48
up vote 2 down vote accepted

If the sub-figures should get ordinary captions like "Figure 1" one could either use \captionbox offered by the caption package (which will align the sub-figures by their first caption line), or use \parbox or minipage with alignment parameter.

Example code:





% or \begin{minipage}[b]{\figwidth\textwidth}...\end{minipage}


enter image description here

(Unfortunately \captionbox isn't documented yet but its syntax is identical to \subcaptionbox documented within the subcaption package documentation.)

share|improve this answer
Thank you, that works great, but when I compile it, the figures are labelled as Figure 1:. Is there a way to remove the colon? – superbriggs Mar 6 '13 at 13:53
When using the caption package there should be no colon since the caption package suppresses the colon automatically if there is no caption text given. So are you sure you get a colon when compiling my example document given in my answer? – Axel Sommerfeldt Mar 7 '13 at 7:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.