Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using Context to set a book I have the following problem: Context linebreaks some quotations in a way that makes the quotation sign (in my case a guillemet [sic!]) appear on its own row. How can i prevent this?

I guess I could in some way use a \hbox{around the quote} but I would like to prevent this from happening in the whole document. How can I achieve that?

Above MWE compiled


(Not so minimal working example ...)

\enableregime   [utf-8]
\mainlanguage   [sv]

\setupbodyfont [cmr,10pt] % 10.6 för att fylla 64 sidor 


% Indentera kommande rader i stycken


%% Layout %%
\setuppapersize[A5][A5] % ,landscape
\setuplayout [location=middle,
    height=189mm, % höjd på text+sidfot+sidhuvud -- Dessa tre första är de enda som påverkar brödtextsfältets storlek
        width=95mm, % bredd på text
topspace=22mm, % utrymme över sidhuvud
    backspace=17mm, % utrymme mellan text och rygg
    headerdistance=10pt, % mellan sidhuvud och text
    footerdistance=4mm, % text till sidfot
    bottomspace=4mm, % mellan sidfot och sidslut
    leftmargindistance=2mm, % text till vänstermarginal
    leftedge=2mm, % vänstermarg rygg
    rightmargin=32mm, %33 justera rightedge och margin efter skrivarens fysiska marginal
    rightedge=3mm, %2


När jag som liten uppgett att teckningen föreställer \quotation{Tomtarnas eld i skogen} kanske det inte alls var menat som en optisk liknelse av denna händelse, utan som en annan typ av {\em teckning} av tomtarnas eld i skogen.

share|improve this question
A \break before the quotation is a workaround for this particular case. –  PetaspeedBeaver Mar 6 '13 at 10:41
A better workaround is to use left=»\nobreak. –  Marco Mar 6 '13 at 10:48
@Marco That sounds like a solution to me, so many thanks! But I'm eager to hear about even more refined solution ... Acually I'm surprised that this break does occur at all, it seems just as unwanted as breaking a word with o-ne letter left on the first line. –  PetaspeedBeaver Mar 6 '13 at 10:54

1 Answer 1

up vote 8 down vote accepted

Here are two workarounds which both result in the quotation mark sticking to the text.

The simplest way is to prevent the line break using left=»\nobreak. Another solution is to set up the delimited text as part of the language setup using \setuplanguage.

Here's a complete example:

\setuplayout [width=10cm]
  %% [sv]

  När jag som liten uppgett att teckningen föreställer
  \quotation{Tomtarnas eld i skogen} kanske det inte alls
  var menat som en optisk liknelse av denna händelse.

The sv argument is optional and applies the setup only for Swedish.

Edit: This issue was fixed in beta 2013.03.10 14:36. A break after the left symbol is now prevented by default.

share|improve this answer
Thank you @marco! Why does "setting up the delimited text as part of the language" prevent the splitting? What's the difference of defining it in \setupdelimitedtext? –  PetaspeedBeaver Mar 6 '13 at 11:36
@PetaspeedBeaver It inserts a \nobreak internally. However, I'm unsure if the behaviour you observed is intended. IMO it makes sense to always prevent a break in this case. You can reduce your code to a minimal example (10 lines is sufficient to demonstrate the issue) and post it on the context mailing list. –  Marco Mar 6 '13 at 11:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.