Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following typical conventions, bibliographical information missing from the publication, but which can be reliably recovered, should be printed between square brackets []. When this applies to the name of the author, this is printed somewhat awkwardly both in the citations and in the bibliography. In the example below, I would like the citations to appear as

([Lennon 1970]; Lennon 1972)

and the references to appear as

[Lennon, John] ([1970]). [Peace on earth]. [London].

Lennon, John (1972). More peace on earth. London.

\documentclass{article}
\usepackage{csquotes,filecontents}
\usepackage[style=authoryear,dashed=false]{biblatex}
\begin{filecontents}{\jobname.bib}
@BOOK{lennon1970,
    AUTHOR = "[John Lennon]",
    TITLE = "[Peace on earth]",
    YEAR = "[1970]",
    LOCATION = "[London]"}
@BOOK{lennon1972,
    AUTHOR = "John Lennon",
    TITLE = "More peace on earth",
    YEAR = "1972",
    LOCATION = "London"}
\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\parencites{lennon1970}{lennon1972}.
\printbibliography
\end{document}

enter image description here

share|improve this question
    
Is it only the whole author list that might be missing? Or can individual names be missing as well? –  Audrey Mar 6 '13 at 20:32
    
@Audrey I don't understand your question. –  Sverre Mar 6 '13 at 20:37
    
Consider the case where there is more than one author. Are you wanting to handle situations like: {McCartney, Paul and [Lennon, John]}? –  Audrey Mar 7 '13 at 1:08
    
No, I don't need that right now. Plus I guess the main reason for filling in missing information in brackets is to avoid totally empty slots for author, date, name of publication, and such. If at least one author is given in the publication, there's no pressing need to include other non-specified ones. –  Sverre Mar 7 '13 at 11:47
add comment

2 Answers

I've never done this, but you might try enclosing your text within the bib file (e.g. "[London]") with curly braces: "{[London]}".

share|improve this answer
2  
That'll treat [John Lennon] as a single, inseparable unit, which is not what I'm looking for. –  Sverre Mar 6 '13 at 17:57
add comment

Building on Andy K.'s answer, the following seems to work for me:

@BOOK{lennon1970,
    AUTHOR = "{[Lennon, John]}",
    SORTNAME = "John Lennon",
    SHORTAUTHOR = "{[Lennon]}",
    TITLE = "[Peace on earth]",
    YEAR = "[1970]",
    LOCATION = "[London]"}

enter image description here

It's not perfect, of course. I'm pretty sure you'll still run into problems with ibidem. clashes as [Lennon] differs from Lennon. But apart from adding an anonymous entry option and its corresponding machinery in your .bbx file, this might be a good short term workaround.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.