Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Background

Wrote a manual in LyX. The PDF is two-sided. Using KOMA Script v2. The pages are 8.5" x 11".

Problem

The spacing on the margins is not printer-friendly, it is reversed:

Image

Since this page is an even-numbered page (4), the print shop said that the extra space must be on the right-hand side. The extra space (for binding) is currently on the left-hand side (of even pages).

Question

How can the margins be swapped so that the larger space is on the right (for even page numbers) while maintaining the same total margin space?

Ideas

  • Tried adding a blank page to the beginning of the manual.
  • \KOMAoptions{BCOR=3cm}\recalctypearea

The latter results in the margins having been flipped around, but with different spacing.

Thank you!

share|improve this question
    
BTW for non-KOMA docs using geometry package there is bindingoffset option, which respects oneside or twoside styles. –  przemoc Jul 4 '11 at 11:44

3 Answers 3

up vote 12 down vote accepted

It is normal that the outside margins are larger than the inside margins. However, KOMA-script/typearea supports the specification of a binding correction. That is, specifying how much space will be lost on the inside of the pages due to binding. The effect is that it shifts the text to the outside by that amount.

You specify the binding correction by passing the BCOR option to the documentclass: \documentclass[BCOR=3cm]{scrbook}. Alternatively, you can also add \KOMAoptions{BCOR=3cm}\recalctypearea to your preamble.


Edit: One way to switch margins is to add the following to your preamble:

\let\tmp\oddsidemargin
\let\oddsidemargin\evensidemargin
\let\evensidemargin\tmp
\reversemarginpar

This will exchange the margin sizes and print marginpars on the inside. I don't know whether that switching has any other unintended side-effects.

share|improve this answer
    
@Dave, well typearea tries to calculate the page layout according to what its author thinks is the best way (the exact algorithm is described in the koma manual). You can try setting a higher number of division (by passing something like 'DIV=10' to the documentclass). If you want absolute control over the margin sizes, the koma manual says that you should just use the geometry package, which lets you set specific margin sizes. –  Caramdir Feb 3 '11 at 1:36
2  
You are right that even numbered pages should be on the left. But typically the outside margin is the larger one (just look at any book). So for even numbered pages the right margin should be larger. –  Caramdir Feb 3 '11 at 1:42
    
Sorry, i meant to say: ”... for even numbered pages the left margin should be larger”. –  Caramdir Feb 3 '11 at 2:06
    
@Dave: Shouldn't they just tell you what binding correction they need and leave the rest up to you? I don't see any easy and non-hackish way to switch margins in KOMA-Script, but I am really no expert on what KOMA can do. –  Caramdir Feb 3 '11 at 2:14
    
@Caramdir: I cracked open The Mythical Man-Month. Indeed, just as you said, and just as shown in the figure. –  Dave Jarvis Feb 3 '11 at 2:16

The default layout is exactly right. The idea is that when you open the book flat on the table, the white space at the borders and in the middle (between the even and odd pages of the text) are the same width (for balance). The memoir documentation (memman.pdf) and I believe the KOMA bundle documentation also explain all this in great length.

share|improve this answer

I had the same problem. Even numbered pages would be inverted margin-wise and page numbers would appear on the ‘inner' side of the page. For me though, the chapter title in the header was on the wrong side as well. E.g. on page 4 it read "Chapter 1.4 xxx" on the left (inner) side and since I put my pagenumbers in the footer those too appeared at the page's inner margin.

So in my case, everything including margins, page header and footer was simply inverted. However, neither my table of contents, nor list of tables and figures were inverted, so I concluded there was something immediately after \listoftables that was causing the inverted margins etc. What I then found was a \clearpage which I put there so that the next chapter doesn't start on the same page as the list of tables.

Look for a \clearpage in your twoside-enabled document and remove it or replace it with a \cleardoublepage if you absolutely need it because \clearpage will cause everything to invert.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.