Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use TeX Live 2012 on Windows 8 and would like to use an EPS image. I usually use PNG, but in this case PNG is too pixelated.

I found that epstopdf is the preferred solution and that TeX Live (starting in 2010) converts on the fly. TeX Live thinks it converted the file, but can't find it because it doesn't exist (log file below). I tried using absolute file references and turning off all other graphics packages, but the symptoms don't change.

This is a little deeper than I've gotten in TeX and would appreciate any help.

(c:/texlive/2012/texmf-dist/tex/latex/latexconfig/epstopdf-sys.cfg
File: epstopdf-sys.cfg 2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Liv
e
))
(./payout_content.tex
Package epstopdf Info: Source file: <../figures/gz_figure_1.eps>
(epstopdf)                    date: 2013-03-08 09:16:48
(epstopdf)                    size: 80137 bytes
(epstopdf)             Output file: <../figures/gz_figure_1-eps-converted-to.pd
f>
(epstopdf)             Command: <repstopdf --outfile=../figures/gz_figure_1-eps
-converted-to.pdf ../figures/gz_figure_1.eps>
(epstopdf)             \includegraphics on input line 6.
runsystem(repstopdf --outfile=../figures/gz_figure_1-eps-converted-to.pdf ../fi
gures/gz_figure_1.eps)...executed safely (allowed).

Package epstopdf Info: Result file: <../figures/gz_figure_1-eps-converted-to.pd
f>.


! Package pdftex.def Error: File `../figures/gz_figure_1-eps-converted-to.pdf' 
not found.

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.6 ...   \includegraphics{../figures/gz_figure_1}

Using draft setting for this image.
Try typing  <return>  to proceed.
If that doesn't work, type  X <return>  to quit.
share|improve this question
1  
Not sure but it would simplify the interaction of the various programs a lot if instead of ../figures/gz_figure_1 you just had gz_figure_1 and put the file in the current directory. Alternatively there is no need to convert this while doing atex you can just run ps2pdf gz_figure_1.ps and that should make a pdf file which pdflatex will then see, –  David Carlisle Mar 8 '13 at 15:02
    
@DavidCarlisle -- Wow. That does it. The file must be in the same directory with epstopdf? I tried full paths, but I guess it has to be same directory. Thanks! –  Richard Herron Mar 8 '13 at 15:07
    
It's probably possible to configure things so it doesn't have to be in the same directory but it's easier just to simplify things so it works rather than configure things in a complicated way:-) –  David Carlisle Mar 8 '13 at 15:12
    
@RichardHerron See note at the end of section 1.3 in documentation of epstopdf (it’s part of the oberdiek bundle). –  Speravir Mar 8 '13 at 23:58

2 Answers 2

up vote 6 down vote accepted

It would simplify the interaction of the various programs a lot if instead of ../figures/gz_figure_1 you just had gz_figure_1 and put the file in the current directory.

Alternatively there is no need to convert this while doing latex you can just run

ps2pdf gz_figure_1.ps 

and that should make a pdf file which pdflatex will then see.

share|improve this answer
1  
Thanks! FWIW, I added the dEPSCrop option so that ps2pdf doesn't embed in the eps file in a full page pdf file. That is, I run ps2pdf -dEPSCrop gz_figure_1.esp. –  Richard Herron Mar 8 '13 at 15:21

This sounds a bit like this.

Try to insert \epstopdfsetup{outdir=./} into your header to make sure epstopdf generates the pdf files in the proper directory.

share|improve this answer
    
Thanks! This does it, too. –  Richard Herron Mar 11 '13 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.