Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How can I force the csquotes package to always show quotations marks in my block quotes, regardless of the language etc...?

Tried this, but no cigar:

\usepackage{csquotes}[english=british] % hopefully this will show quotes

Also, there was a solution here using:

\renewenvironment{quoteblock}{\openautoquote}{\closeautoquote}

but it seems like quoteblock was removed in a recent version.

share|improve this question
    
Well, just do \newenvironment. –  egreg Mar 10 '13 at 16:03
    
@egreg I want it to work with all the csquote commands, like displayquote and foreigndisplayquote, hyphendisplayquote etc... –  drozzy Mar 10 '13 at 16:05
    
Please, state clearly in your question what you're looking for. As it stands, it's difficult to understand what you're asking for. –  egreg Mar 10 '13 at 16:06
3  
Shouldn’t it be \usepackage[english=british]{csquotes}? –  Qrrbrbirlbel Mar 10 '13 at 16:14
    
@drozzy Please, try explaining more clearly your problem. –  egreg Mar 11 '13 at 0:22
add comment

2 Answers

Indeed quoteblock was removed in version 5.0 of csquotes. The behaviour is controlled now by \mkblockquote for \blockquote and relatives, and by the pair \mkbegdispquote and \mkenddispquote for the environment displayquote and relatives. All these have to be redefined:

\documentclass{article}

\usepackage[british]{babel}
\usepackage{csquotes}
  % for commands "\blockquote" and related:
  \renewcommand{\mkblockquote}[4]{\openautoquote#1\closeautoquote#2#4#3}
  % for environments "displayquote" and related:
  \renewcommand{\mkbegdispquote}[2]{\openautoquote}
  \renewcommand{\mkenddispquote}[2]{\closeautoquote#1#2}

\usepackage{kantlipsum}% for some dummy text

\begin{document}

\kant[1]

\noindent\hrulefill

\blockquote{%
% extract from \kant[2]%
Let us suppose that the noumena have nothing to do with necessity,
since knowledge of the Categories is \enquote{\textbf{a posteriori}}.
Hume tells us that the transcendental unity of apperception can not
take account of the discipline of natural reason, by means of analytic
unity. As is proven in the ontological manuals, it is obvious that the
transcendental unity of apperception proves the validity of the
Antinomies.%
}

\noindent\hrulefill

\begin{displayquote}
% extract from \kant[3]%
As is shown in the writings of Aristotle, the things in themselves
(and it remains a mystery why this is the case) are a representation
of time. Our concepts have lying before them the paralogisms of
natural reason, but our \enquote{\textbf{a posteriori}} concepts have
lying before them the practical employment of our experience.
\end{displayquote}

\end{document}

Note also, that the language is set by babel here, and csquotes reads this setting (see package option autostyle). I intentionally added an \enquote command (marked bold in output) inside of both blockquote variations. By the way polyglossia would also be possible.


Should this not be, what you want, I can only suggest, you should read in csquotes documentation, what is written to package options threshold, thresholdtype and perhaps parthreshold, to the command \blockquote and the section for display environments.

share|improve this answer
add comment

A simple and elegant solution, is to use the package quoting, with the option begintext and endtext. An MWE:

\documentclass{article}
\usepackage{csquotes}
\usepackage[begintext=``, endtext='']{quoting}
\SetBlockEnvironment{quoting}
\SetBlockThreshold{1} 
\usepackage[utf8]{inputenx}
\usepackage[T1]{fontenc}
\usepackage[nopar]{lipsum}

\begin{document}

\lipsum[1]

\blockquote{\lipsum[3]}

\lipsum\par

\end{document}

Which will give the output:

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.