Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to make a feynman diagram using feynmf. My code is

\documentclass[a4paper,11pt]{article}

\usepackage{xcolor}
\usepackage{amsthm}
\theoremstyle{definition}
\newtheorem{exe}{Exercise}
\newcommand*{\mybox}[2]{\colorbox{#1!30}{\parbox[t]{.88\linewidth}{#2}}}

%~~~~~~~~~~~~~~~~~~~~Feynman Diagramms~~~~~~~~~~~~~~~~~~~~~~~~~~
\usepackage{feynmp}
\DeclareGraphicsRule{.1}{mps}{.1}{}
%\DeclareGraphicsRule{*}{mps}{*}{}
%
\makeatletter
\def\endfmffile{%
  \fmfcmd{\p@rcent\space the end.^^J%
          end.^^J%
          endinput;}%
  \if@fmfio
    \immediate\closeout\@outfmf
  \fi
  \ifnum\pdfshellescape=\@ne
    \immediate\write18{mpost \thefmffile}%
  \fi}
\makeatother

\begin{document}

\begin{exe}\mybox{gray}{Show that $g_{\mu\nu}g^{\mu\nu}=4$}\\

\noindent\textbf{Solution:} \unitlength = 1mm

\begin{figure}[H]
\centering
\begin{fmffile}{pair}   %file.mf will be created for this feynman diagram  
  \fmfframe(1,7)(1,7){  %Sets dimension of Diagram
   \begin{fmfgraph*}(70,45) %Sets size of Diagram
    \fmfleft{i1}    %Sets there to be 2 sources 
    \fmfright{o1,o2}    %Sets there to be 2  outputs
    \fmflabel{$\gamma$}{i1} %Labels one of the left sources
%    \fmflabel{$e^-$}{i1} %Labels one of the left sources
    \fmflabel{$e^-$}{o1} %Labels one of the right outputs
    \fmflabel{$e^+$}{o2} %Labels one of the right outputs
    \fmf{photon}{i1,v1} %Connects the sources with a vertex.
%    \fmf{fermion}{i1,v1} %Connects the outputs with a vertex.
%    \fmf{fermion}{v1,v2} %Labels the conneting line.
    \fmf{fermion}{v1,o1}
    \fmf{fermion}{v1,o2}
   \end{fmfgraph*}
  }
\end{fmffile}\caption{Feynman Diagram}
\end{figure}

\end{exe}
\end{document}

Once I run this code, a *.mp file is produced. I run metapost and then LaTeX again. The thing is that there is no feynman produced and I get a *.txt that says

This is MetaPost, Version 1.005 (MiKTeX 2.8) (preloaded mem=mpost 2013.3.11)  11 MAR 2013 16:56
**C:\Users\thanos\Documents\^^d6^^d4^^c5\2nd Semester\Elementary Particle Physi
cs\Homework\testMF\pair.mp

! Emergency stop.
<*> C:\Users\thanos\Documents\^^d6^^d4^^c5\2nd
                                               Semester\Elementary Particle ...
*** (job aborted, file error in nonstop mode)

I used to do the same procedure to create such diagrams and everything used to work fine. Any idea on what's going on here?

share|improve this question
    
It works!...... –  Harish Kumar Mar 11 '13 at 15:07
    
Works for me too. Try deleting all the generated files (aux, mp, etc.) and starting the process again. –  Ian Thompson Mar 11 '13 at 15:08
2  
It's failing over a character in your file name, you could first try it in a simpler directory with only ascii letters and numbers in the path, –  David Carlisle Mar 11 '13 at 15:09
    
Thank you all for your suggestions! In particular @DavidCarlisle it was exactly that plus it cannot work with spaces in the path! Thank you very much for your help! –  Thanos Mar 11 '13 at 19:25
add comment

closed as too localized by zeroth, Kurt, Claudio Fiandrino, mafp, lockstep Mar 11 '13 at 16:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.