Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the multicol package for my columns. So far, I have \setlength\columnsep{10pt} in the preamble to set the default column separation. But for one particular page, I'd like to set the columnsep to 30pt.

I wasn't able to get it to work by inserting a new \setlength at the start of the page.

Here's an example:

\documentclass{article}
\usepackage{blindtext}
\usepackage{multicol}
\setlength\columnsep{10pt} % This is the default columnsep for all pages
\begin{document}

\begin{multicols*}{2}
\blindtext

\newpage
\setlength\columnsep{30pt} % I want the columnsep to be wider only on this page. Right now, nothing happens. The default 10pt is still being used.
\blindtext
\columnbreak
\blindtext

\newpage
\blindtext

\end{multicols*}
\end{document}

Any help would be appreciated.

share|improve this question
    
What do you mean by "I wasn't able to"? Could you please provide us with a MWE? –  Vahid Damanafshan Mar 12 '13 at 7:08
    
To add to @VahidDamanafshan ’s comment: Why weren’t you able? What happened when you did insert a \setlength? Nothing? Error message? Weird output? The \columnsep changed for the next page? For all following pages? Please provide a minimal working example (MWE) that shows what you have tried so far. –  Qrrbrbirlbel Mar 12 '13 at 7:19
    
If you mean that you want to change the column space but maintain total width (so change the column width) then you will have to stop the multicols environment, change parameter, and re-start. If you want to keep the column width but just separate the columns so placing them differently on the page, that would be possible. –  David Carlisle Mar 12 '13 at 11:17
    
Just provided a MWE. –  Nelson Mar 12 '13 at 13:11
add comment

1 Answer

up vote 2 down vote accepted

To change the column width in the mid document, you should close the previous multicols, set the new \columnsep, and then start a new multicols environment. Try the following code:

\documentclass{article}
\usepackage{blindtext}
\usepackage{multicol}
\setlength\columnsep{10pt} % This is the default columnsep for all pages
\begin{document}

\begin{multicols*}{2}
\blindtext
\end{multicols*}
\newpage
\setlength{\columnsep}{30pt} % I want the columnsep to be wider only on this page. Right now, nothing happens. The default 10pt is still being used.
\begin{multicols}{2}
\blindtext
\end{multicols}
\newpage
\setlength\columnsep{10pt}
\begin{multicols*}{2}
%\columnbreak
\blindtext
\end{multicols*}
\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.