Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using scrbook to typeset a document and I'm using \part for formatting the parts of it.

The default output renders \part{Mytitle} into

Part I.

Mytitle

Now I'd like to get rid of the period after "Part I." In the KOMA-Script guide I have only found options to generally switch off punctuation after every part, chapter, section etc.

So I tried \renewcommand{\thepart}{\Roman{part}} but this strangely still puts a period after the roman number. However, \renewcommand{\thepart}{\arabic{part}} and \renewcommand{\thepart}{\arabic{part}.} produce the expected difference.

So what is so special with roman numbering here?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

There is not automatic solution to this, but it is not hard to redefine the format of the part headings. The default is

\newcommand*{\partformat}{\partname~\thepart\autodot}

you just need to redefine this removing the \autodot.

Part sample

Chapter/section sample

\documentclass[numbers=enddot]{scrbook}

\renewcommand*{\partformat}{\partname~\thepart}

\begin{document}
\part{My part}
\chapter{My chapter}
\section{My section}
\part{My part}
\chapter{My chapter}
\section{My section}
\end{document}
share|improve this answer
    
Great. I think this is the simplest/shortest solution. Thank you very much. –  absurd Mar 13 '13 at 16:50
add comment

KOMA-Script decides in the default setting that an “end dot” will be used if any section numbering macros (\thepart, \thechapter, …) use Roman numbers or any letters.

When you change \thepart to use \arabic, it will switch automaticaly to “no end dot”.

Do you want

  • to never have an end dot, or
  • to not have an end dot with Roman part numbers?

No end dot in any numbers

You can use the numbers class option with the value noenddot.
See

Code

\documentclass[numbers=noenddot]{scrbook}
\begin{document}
\part{Mytitle}
\chapter{My other title with no end dot}
\end{document}

No end dot in the part number

If you only want the part’s number to not be followed by a dot but all other section numbers followed by one, KOMA-Script does not provide an interface for that.

My proposal:

Use the default setting for numbers (i.e. auto; because \thepart still uses \Roman all other section numbers will get the dot either way) and just overwrite \partformat:

\renewcommand*{\partformat}{\partname~\thepart}
%\newcommand*{\partformat}{\partname~\thepart\autodot}% <- original defintion in scrbook.cls

This will remove \autodot from the definition.

Code

\documentclass{scrbook}
\renewcommand*{\partformat}{\partname~\thepart}
\begin{document}
\part{Mytitle}
\chapter{My other title with an end dot}
\end{document}

Output (both)

enter image description here

share|improve this answer
    
Is there a way to limit this to the end dot after parts (so that chapters would still get an end dot)? –  Jake Mar 13 '13 at 16:05
    
@Jake I don't think that there's an automatic solution for this. But it shouldn't be that complicated to get this done. –  Benedikt Bauer Mar 13 '13 at 16:30
2  
@Jake See my updated answer. As Benedikt Bauer already said: There's no interface for that. I think this is the easiest solution. As far as I can see, \partformat will not be redefined by KOMA-Script anywhere, so it should be safe. –  Qrrbrbirlbel Mar 13 '13 at 16:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.