Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the template http://www.latextemplates.com/template/masters-doctoral-thesis, which I think is great. However, this template has somehow been set up to make bigger line spacing instead of indenting paragraphs, and I can't figure out how. I would like to go back to indenting and not line spacing. Does someone know how to change this?

Note: There are some \parskip and \parindent commands in the .cls file, but they seem to be for special sections of the paper.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

The class indeed sets zero parindent and a nonzero parskip. Moreover it uses vmargin which is known to be incompatible with some packages, notably atbegshi which is used by various others.

I suggest you to modify it, changing lines from 66 to 89; here's the original (with line numbers for reference):

 66 \usepackage{setspace}
 67 \onehalfspacing
 68 \setlength{\parindent}{0pt}
 69 \setlength{\parskip}{2.0ex plus0.5ex minus0.2ex}
 70 \usepackage{vmargin}
 71 %----------------------------------------------------------------------------------------
 72 %       MARGINS
 73 %----------------------------------------------------------------------------------------
 74 \setmarginsrb  { 1.5in}  % left margin
 75                         { 0.6in}  % top margin
 76                         { 1.0in}  % right margin
 77                         { 0.8in}  % bottom margin
 78                         {  20pt}  % head height
 79                         {0.25in}  % head sep
 80                         {   9pt}  % foot height
 81                         { 0.3in}  % foot sep
 82 %----------------------------------------------------------------------------------------
 83 \raggedbottom
 84 \setlength{\topskip}{1\topskip \@plus 5\p@}
 85 \doublehyphendemerits=10000       % No consecutive line hyphens.
 86 \brokenpenalty=10000              % No broken words across columns/pages.
 87 \widowpenalty=9999                % Almost no widows at bottom of page.
 88 \clubpenalty=9999                 % Almost no orphans at top of page.
 89 \interfootnotelinepenalty=9999    % Almost never break footnotes.

Here's the modified code

%%% Uncomment the following two lines if you really want doublespacing
%\usepackage{setspace}
%\onehalfspacing

\usepackage{geometry}
\geometry{includehead,includefoot,
  left=1.5in,
  top=0.6in,
  right=1.0in,
  bottom=0.8in,
  headheight=20pt,
  headsep=0.25in,
  footskip=0.3in}

\doublehyphendemerits=10000       % No consecutive line hyphens.
\brokenpenalty=10000              % No broken words across columns/pages.
\widowpenalty=9999                % Almost no widows at bottom of page.
\clubpenalty=9999                 % Almost no orphans at top of page.
\@clubpenalty=9999                % Almost no orphans at top of page.
\interfootnotelinepenalty=9999    % Almost never break footnotes.

Comments

  1. Double spacing is bad, avoid it if you can.

  2. vmargin is not to be used.

  3. Setting a flexible \topskip is a quite bad idea.

  4. The final settings of the penalty parameters may seem a good idea, but it's not. However, I didn't touch them, except adding the setting of \@clubpenalty, which is the real parameter in LaTeX for controlling orphan lines.

  5. \raggedbottom in a twosided document is not recommendable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.