TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using supertabular in multicols enviroment based on this thread's accepted answer multicolumn long table or enumeration. But there is sometimes header and empty table body left in new column/page (eg. when i change counter "n" to 19 - first column is full and only header is in second column). I've also tried this solution How to disable pagebreak on \hline in supertabular? but it doensn't help. Number of rows I create is arbitrary. Is there a way to remove these headers with no body (without removing all headers)?

EDIT: example

            \advance\n by1
                    \hfill T\hfill\hfill F\hfill\hskip0pt\endgraf
                    \hrule height3ex
                    \hrule width\linewidth height0pt
    \tablehead{Item \#&\\}
share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.