Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the following BibTeX source

@INPROCEEDINGS{Lincke2008,
  author = {Rüdiger Lincke and Jonas Lundberg and Welf Löwe},
  title = {Comparing software metrics tools.},
  booktitle = {ISSTA},
  year = {2008},
  editor = {Barbara G. Ryder and Andreas Zeller},
  pages = {131-142},
  publisher = {ACM},
  added-at = {2008-08-04T00:00:00.000+0200},
  biburl = {http://www.bibsonomy.org/bibtex/2c28c4fff6d811b643940228935a20e28/dblp},
  crossref = {conf/issta/2008},
  date = {2008-08-04},
  description = {dblp},
  ee = {http://doi.acm.org/10.1145/1390630.1390648},
  interhash = {69e9d6ded70716bc2bb9319abfbb015f},
  intrahash = {c28c4fff6d811b643940228935a20e28},
  isbn = {978-1-60558-050-0},
  keywords = {dblp},
  url = {http://dblp.uni-trier.de/db/conf/issta/issta2008.html#LinckeLL08}
}

I'm managing my BibTeX items with JabRef. Now if I want to cite this item and while generating the PDF i get the following error:

! Package inputenc Error: Keyboard character used is undefined
(inputenc)                in inputencoding `utf8x'.

See the inputenc package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.29 R�
       diger Lincke, Jonas Lundberg, and Welf L�we.

I think the problem is the character ö. How can I avoid that? I also had similar problem with the character é.

share|improve this question
add comment

2 Answers

up vote 8 down vote accepted

Instead of actually entering the ö and é characters in your source, type \"{o} and \'{e}.

Or rather: Yrjö Engeström as {Yrj{\"o} Engestr{\"o}m}.

share|improve this answer
    
in the BibTeX source or where? –  RoflcoptrException Feb 5 '11 at 0:18
1  
@Roflcoptr - Anywhere they appear in your source. Edited for clarity. –  Andrew Arnold Feb 5 '11 at 0:19
    
Then i get this error: ! Package inputenc Error: Keyboard character used is undefined (inputenc) in inputencoding `utf8x'. See the inputenc package documentation for explanation. Type H <return> for immediate help. ... l.29 R� diger Lincke, Jonas Lundberg, and Welf L\"{o}we. ? –  RoflcoptrException Feb 5 '11 at 0:21
1  
@Roflcoptr - Make sure your source files are encoded in ANSI instead of UTF-8. –  Andrew Arnold Feb 5 '11 at 0:22
    
@Andrew S. Arnold Thanks a lot, encoding the database in UTF-8 solved the problem –  RoflcoptrException Feb 5 '11 at 0:30
show 1 more comment

If you use utf8(x) in your tex file, ensure that your BibTeX source file is utf8 encoded as well.

You might use

  • an editor supporting different encodings, opening (in latin1 or accordingly) and save it in utf8 encoding

  • recode

  • iconv

If you don't use utf8(x) in your tex file, load inputenc with the respective option. Or convert the tex file to the same encoding as the BibTeX source and adjust the inputenc option accordingly.

To sum up, the encoding of all involved files should be the same and match the inputenc option.

share|improve this answer
    
Thanks a lot, encoding the database in UTF-8 solved the problem! –  RoflcoptrException Feb 5 '11 at 0:30
1  
But BibTeX doesn't really do UTF8... –  Martin Schröder Jan 26 '12 at 22:14
    
@MartinSchröder, what are the limitations? The fact that utf8 in a .bib file only works with a utf8-input-encoded TeX-document? Or are there other pitfalls with utf8 and BibTeX? –  maxschlepzig Mar 28 '12 at 12:47
    
@maxschlepzig: How would a 7-bit program (which BibTeX is) sort UTF-8 strings? How would it generate labels etc.? –  Martin Schröder Mar 28 '12 at 15:33
    
@MartinSchröder, Sorting of UTF-8 strings as arrays of unsigned bytes will produce the same results as sorting them based on Unicode code points. ;) - but fair enough, using non-numeric labels would be a problem. –  maxschlepzig Mar 28 '12 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.