Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a newcomer to the world of LaTeX. After searching around on the net to see what others might think, I have installed Tex Live 2012 and TeXstudio 2.5.2. I understand that now I have to setup my system somehow to display things properly, every time I compile my documents.

I have downloaded some examples, that actually compile and I can see the end result. The thing is that I would like to use the integrated Windows fonts (like Cambria or Calibri).

I have read somewhere that to do this I would need to use XeTeX, as it is able of Unicode Formatting(?, not sure). So the guide was mentioning that I would need to navigate to Tools > User > User Commands > Edit User Commands and make a new command named XeTeX that I could then use in Options > Configure TeXstudio.

The problem is that this submenu is not there! I navigate to Tools > User and nothing appears. Is that a bug or am I doing something wrong?

This suggestion for Cambria and Calibri use is here , paragraph 5. I am under Windows 7 x64 and I have installed everything in folders without spaces in their names. (I saw somewhere it really mattered!)

EDIT: I have also installed version 2.5.1 and the latest SVN version (I don't know the difference :) ), but the menu is also not visible.

EDIT2: OK, I'm pretty embarrassed... I found the user manual and there it is stated that User Commands are built from Options > Configure TeXstudio > Build > Add user command. When I navigate there, a window pops up with 2 columns, that you can add stuff. I guess it's something of a visual way to make macros instead of writing them. Is there a way to write them, then?

share|improve this question
    
Do you actually want to use XeTeX or really XeLaTeX? XeLaTeX is available without a problem as a compiler. If you don't need XeLaTeX but XeTeX you can change the command for XeLaTeX to xetex.exe (→ Options → Configure TeXstudio → Commands). If you really want XeTeX as a user command you can create one in the Build section of the Configure TeXstudio window. This can be used in the Meta Commands section with txs:///user (for example). A shortcut can be assigned too. –  Qrrbrbirlbel Mar 18 '13 at 18:11
    
@Qrrbrbirlbel : Well, to tell you the truth I have no idea. I will try with XeLaTeX. The User Commands sub-menu is just the shortcut menu for all the user built commands! –  Dima1982 Mar 18 '13 at 18:15
    
The linked article uses the xelatex.exe but names the user command misleadingly “XeTeX”. If your document starts with \documentclass you use XeLaTeX and not XeTeX (→ What is the difference between TeX and LaTeX?), and then there’s no need to create a User Command. –  Qrrbrbirlbel Mar 18 '13 at 18:20
    
@Qrrbrbirlbel: Thank you for your reply. I will try this and post the result asap! –  Dima1982 Mar 18 '13 at 18:30
    
Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say "thank you" to users who helped you. –  hpesoj626 Mar 19 '13 at 1:23

2 Answers 2

you can use it with

User > User Commands > (ShortCut) or click on name

instead of using the edit button. Maybe that you have to restart texstudio after editing the user commands.

share|improve this answer
    
thank you for the quick reply! The problem is that when I navigate to Tools > User there is nothing there! I cannot see User Commands! –  Dima1982 Mar 18 '13 at 17:29
    
did you a restart after editing the new user command –  Herbert Mar 18 '13 at 17:39
    
I cannot see the User Command to make a new one. That's the problem. :) Let me clarify. When I navigate to Tools > Commands I can see a submenu with things like : Latexmk, latex... etc. When I navigate to Tools > User there is nothing! No submenu. I am perplexed. –  Dima1982 Mar 18 '13 at 17:42
    
ok, I just saw that this is only available in an old version of TeXStudio. I'll install the newest version. –  Herbert Mar 18 '13 at 17:46
    
In the newest version (SVN 2.5.2), you create the command in Options > Configure TeXstudio > Build. Then look for the User Commands menu. Afterwards, you can see your custom commands sequences in Tools > User. –  hpesoj626 Mar 19 '13 at 1:21

Option->Configure TeXstudio->Shortcuts->Menus->Tools->Commands->XeLaTeX

Double click on the cell, intersection of XeLaTeX and Current Shortcuts

share|improve this answer
1  
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  texenthusiast Aug 5 '13 at 14:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.