Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'd like to put a figure next to a list which contains a footnote. Without the footnote everything works fine. But when I add the footnote, the figure gets shifted to the right and partly appears to be outside the frame margin. I'd like to put the figure back to where it was before I added the footnote. Here is an MWE:

\documentclass{beamer}

\begin{document}

\frame{\frametitle{Title}

\begin{columns}[c]

    \begin{column}[r]{5cm}
        \begin{itemize}[<+->]
        \item The first item
        \item The second item\footnote{A footnote}
        \item The third item
        \end{itemize} 
    \end{column}

    \begin{column}[l]{5cm}
        {\rule{2cm}{2cm}}%
        %\includegraphics
    \end{column}

\end{columns}   

}

\end{document}

Any idea how to solve this problem?

share|improve this question
1  
you could use \footnotemark[num] in the item and \footnotetext[num]{text} outside of columns. check out this question –  jens_bo Mar 19 '13 at 11:34
    
@jenson_bo unfortunately, in this case, \footnotemark, \footnotetext doesn't solve the problem. –  Gonzalo Medina Mar 19 '13 at 12:18
    
@Gonzalo For me it does. Did you add \footnotetext after \end{columns}? –  jens_bo Mar 19 '13 at 12:35
    
@jenson_bo but then the footnote text will be moved to the end of the frame which could be achieved simply by using the frame option for \footnote, as in \footnote[frame]{A footnote}. I assumed that AnjaM's intent was to have the footnote text close to the itemized list. –  Gonzalo Medina Mar 19 '13 at 13:05

1 Answer 1

up vote 3 down vote accepted

You can use a minipage:

\documentclass{beamer}

\begin{document}

\begin{frame}
\frametitle{Title}
\begin{columns}[c]

    \begin{column}[l]{5cm}
    \begin{minipage}[t]{5cm}
        \begin{itemize}[<+->]
        \item The first item
        \item The second item\footnote{A footnote}
        \item The third item
        \end{itemize}
    \end{minipage} 
    \end{column}

    \begin{column}[l]{5cm}
        \rule{2cm}{2cm}%
        %\includegraphics
    \end{column}

\end{columns}   
\end{frame}

\end{document}

An image of the third slide:

enter image description here

share|improve this answer
    
Thanks a lot, this works! Do you know why the figure shifted without the minipage environment? I don't really understand why the minipage environment changes the behaviour. –  AnjaM Mar 19 '13 at 12:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.