Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I could copy the sentence "МАТЕМАТИЧКИ ВЕСНИК" into the LaTeX, however when I press the dvi, it does not show in the dvi. How to make the dvi show the sentence "МАТЕМАТИЧКИ ВЕСНИК"?

share|improve this question

closed as too localized by Jake, Speravir, Kurt, Guido, Thorsten Mar 26 '13 at 7:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4  
Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. My guess would be that you need some package that can process cyrillic (?) letters, like \usepackage{polyglossia} \setmainlanguage{russian} or \usepackage[utf8]{inputenc} \usepackage[russian]{babel}, see tex.stackexchange.com/questions/816/cyrillic-in-latex –  Anke Mar 20 '13 at 8:52
1  
Have you tried converting the dvi to pdf or generating pdf from tex? –  Marc van Dongen Mar 20 '13 at 9:06
    
No. I am editing. –  John Mar 20 '13 at 9:10

2 Answers 2

up vote 3 down vote accepted

For a small text in Russian, perhaps the cheapest method is to use the OT2 encoding; in this way no juggling with input encodings is needed.

\documentclass{article}
\usepackage[OT2,T1]{fontenc}
\DeclareRobustCommand{\russtext}[1]{%
  {\fontencoding{OT2}\fontfamily{wncyr}\selectfont#1}%
}
\begin{document}
\russtext{Matematichki Vesnik}
\end{document}

enter image description here

share|improve this answer
    
Very helpful, thanks. –  John Mar 21 '13 at 0:11

Here is a minimal working example:

\documentclass{article}
\usepackage[koi8-r]{inputenc}
\usepackage[english,russian]{babel}
\begin{document}
\section{Раздел}
Текст на русском языке
\end{document}

I recommend you to read first some books about latex and after that try to work with it.

share|improve this answer
    
Where should I put it in? –  John Mar 20 '13 at 9:24
    
Just latex it: latex file.tex. –  Eddy_Em Mar 20 '13 at 9:32
    
It cannot operate:( –  John Mar 20 '13 at 9:35
    
Change encoding of file to koi8-r or change [koi8-r] to [utf8] in option of \usepackage{inputenc}. But i recommend you first to read a couple of books about latex. –  Eddy_Em Mar 20 '13 at 9:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.