Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to set maxnames in my biber option, but it doesn't work.

I don't really understand what I'm doing wrong.

My MWE is:

\documentclass[12pt,a4paper,german]{scrartcl}
\setkomafont{section}{\large} 
\usepackage[utf8]{inputenc}
\usepackage{geometry}
\geometry{verbose,a4paper,tmargin=25mm,bmargin=25mm,lmargin=30mm,rmargin=30mm}
\usepackage[bibstyle=authortitle,citestyle=authoryear,backend=biber]{biblatex}
\addbibresource{paul.bib}
\usepackage[german]{babel}
\usepackage{txfonts} %Schriftart Times New Roman

\begin{document}

foobar\cite{pisae2003}



\printbibliography
\end{document}

my paul.bib:

@ARTICLE{pisae2003,
   author = {{Prenzel, Manfred and Baumert, Jürgen and Blum,Werner and Lehmann, Rainer and Leutner, Detlev and Neubrand,Michael and Pekrun,Reinhard Rost,Jürgen and Schiefele, Ulrich}},
   title = {PISA-2003},
   subtitle = {Ergebnisse des zweiten Ländervergleichs. Zusammenfassung},
   url = {http://pisa.ipn.uni-kiel.de/PISA2003_E_Zusammenfassung.pdf},
   lastchecked = {20.\,März.\,2013},
   year = 2005,}
share|improve this question
1  
Welcome to TeX.SE. :) Could you clarify, what is not working? Because your code deosn't involve any maxnames commands in the MWE. Tip: Also, you can make the code stand out by indenting the code with 4 spaces. –  gns-ank Mar 23 '13 at 17:03
4  
You have an additional pair of braces in the author field that should be removed: with your input you're telling Biber that you have only one author (with a very peculiar name). –  egreg Mar 23 '13 at 17:17

1 Answer 1

You have an additional pair of braces in your author field that makes impossible for Biber to count the number of authors: you're specifying, according to the syntax rules, only one author.

For setting the maximum number of authors shown there are various options; here's how you can limit the number of authors shown in citations to three. The file contents* environment is just a convenience for making the example self contained.

\begin{filecontents*}{\jobname.bib}
@ARTICLE{pisae2003,
   author = {Prenzel, Manfred and Baumert, Jürgen and Blum, Werner and 
             Lehmann, Rainer and Leutner, Detlev and Neubrand, Michael and
             Pekrun, Reinhard and Rost, Jürgen and Schiefele, Ulrich},
   title = {PISA-2003},
   subtitle = {Ergebnisse des zweiten Ländervergleichs. Zusammenfassung},
   url = {http://pisa.ipn.uni-kiel.de/PISA2003_E_Zusammenfassung.pdf},
   lastchecked = {20.\,März.\,2013},
   year = 2005,}
\end{filecontents*}

\documentclass[12pt,a4paper,german]{scrartcl}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[german]{babel}

\usepackage{geometry}
\geometry{a4paper,tmargin=25mm,bmargin=25mm,lmargin=30mm,rmargin=30mm}

\usepackage{txfonts} %Schriftart Times New Roman

\usepackage[
  bibstyle=authortitle,
  citestyle=authoryear,
  maxcitenames=5,
  mincitenames=3,
  maxbibnames=1000,
  backend=biber
  ]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}

A citation: \cite{pisae2003}

\printbibliography

\end{document}

Here we're telling LaTeX to show three authors in a citation when the total number of them is more than five. So up to five authors are shown, but when their number is six or more, only the first three will appear in a citation (adjust to what you prefer). Conversely, by setting maxbibnames=1000, we're saying that any list of authors will be printed fully (well, not if there are more than one thousand of them).

The relation between maxbibnames and minbibnames is the same as between maxcitenames and minbibnames.

Setting maxnames is the same as setting maxbibnames and maxcitenames to the same value; similarly for minnames.

enter image description here

share|improve this answer
    
Thank you very much. Now I really understand the thing with maxnames. My problem were the double-braces. Only one thing: In my faculty they want the latin expresssio (et al.) not the german one (u.a.) How can I tell biber to do that? –  paulderfinne Mar 24 '13 at 5:54
1  
OK. I found that in the web (with \DefineBibliographyStrings{german}{ andothers = {{et\,al\adddot}}, } So everything is OK now. Thank you so much foe taking time to help –  paulderfinne Mar 24 '13 at 6:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.