Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the biblatex package in the verbose-trad1 style.

When generating a bibliography at the end of my chapter, all references are listed in alphabetical author, but they are NOT numbered.

Is there a way to have all references numbered? That way, the readers would also have an idea of the number of references in the bibliography.

share|improve this question
1  
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. –  Guido Mar 24 '13 at 12:47
    
Thank you for this information Guido. I'll keep it in mind for the future. –  user27894 Mar 24 '13 at 13:03

1 Answer 1

There are different commands for biblatex to have different styles for citations and the bibliography. For example you can have

\usepackage[
    citestyle=verbose-trad1,  % Your citation style.
    bibstyle=numeric,         % Style for bibliography list. It will be numeric.
    sorting=none,             % The citations will be listed in the order of appearance
    backend=biber             % This is not necessary for newer versions of biblatex as 
                              % it is the default, but it certainly helps to keep things
                              % explicit.
]{biblatex}

For different sorting schemes refer to the p.52 of Biblatex guide.


I guess, that there are also several somewhat related questions on TeX.SX:

Maybe these will be helpful as well.

share|improve this answer
    
Making a distinction between citestyle and bibstyle in my preamble indeed helped to generate a numbered reference list. However, due to numeric style now chosen, it also removed the dashes that were normally used to replace recurrent authors/editors in the bibliography, thus visually grouping items by the same author or editor. I have tried to re-enable this feature by adding dashed=true in my preamble, but this did not work. Any ideas? –  user27894 Mar 24 '13 at 14:26
    
As far as I understand, the dashed option is available only for verbose, authoryear and authortitle styles. Currently, I do not have any suggestions how to solve the problem. Either way, why do you need to number your citations in the bibliography list? –  gns-ank Mar 24 '13 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.