TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to LaTeX and I have encountered a problem with the listings package, I have a space before the :: operator of C++ .

after reading lstlisting with c++: spaces around scope resolution operator I added columns=fullflexible but it doesn't solve the problem.

here are my settings :

   frame=lrtb ,
share|improve this question

closed as unclear what you're asking by Marco Daniel, lockstep, Claudio Fiandrino, Stefan Kottwitz Jul 7 '13 at 11:39

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – egreg Mar 25 '13 at 21:11