Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

If I include the package listings I can't compile my document anymore. There is an error saying:

!No room for new \dimen.\ck ... \else \ermesage{No room...}
File: \latex\sueprtabluar\supertabular.sty

Is this enough information for anyone to help get it running, or maybe there is an other solution printing source code style?

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

Write after the documentclass:

\usepackage{etex}

it enables the capabilities of the etex engine, e.g. more registers for dimensions etc

share|improve this answer
    
thx.. it works. just two, sentences why it fix it? –  user3396 Feb 6 '11 at 21:07
    
done, see edit ... –  Herbert Feb 6 '11 at 21:12
add comment

You seem to load to many packages which require to many dimension registers. Looks like the package which requests the one-to-many is the supertabular package. This has nothing special to do with listings. The reason the error appeared when you started to use it was just that it increased the number of required dimension registers over the available limit.

This is also explained in more detail in the TeX FAQ.

Try to reduce the number of packages you are using. Also check that you are using eTeX which increases the number of registers a lot.

share|improve this answer
    
all engines use etex by default. –  Herbert Feb 7 '11 at 19:11
1  
@Herbert: I thought so. But I didn't knew that the number of registers is not extended by default, therefore I assumed that on his installation etex is somehow disabled. –  Martin Scharrer Feb 7 '11 at 19:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.