Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Today I have just downloaded Basic MiKTeX 2.9 and TeXnicCenter 2.0 Beta (latest version from the website). But my TeXnicCenter is not compiling and producing any output in PDF. It happened before once, so I removed the MiKTeX and TeXnicCenter that I installed before. But still I am having the same problem? Any insight or solution will be appreciated.

share|improve this question
4  
TeXnicCenter is not compiling means--> what are the errors ? Did you Verify a latex installation: Commandline/Terminal. See TeXniccenter configuration screenshot –  texenthusiast Mar 26 '13 at 1:40
4  
Put yourself in the shoes of the community. Now think, how are we supposed to know what might be the problem? You need to give more information in terms of the setup. What errors are you getting? –  Werner Mar 26 '13 at 1:41
4  
Did you configure it to find the path for tex executables? –  Sigur Mar 26 '13 at 1:41
2  
Have you installed first MiKTeX and afterwards TeXnicCenter? I guess not, because TeXnicCenter is able to find an installed MiKTeX and to config itself ... –  Kurt Mar 26 '13 at 2:18
    
Apart from what Kurt writes – also, when you installed TeXnicCenter before MiKTeX, there is cure: Go into “Build” –> “Define Output Profiles…”, remove all existing profiles, and start the “Wizard”. It will ask you for the “Distribution directory”, where you have to input the path to the MiKTeX binaries, i.e. <MiKTeX>\miktex\bin – the bin subfolder is essential here! –  Speravir Mar 26 '13 at 2:35
show 1 more comment

1 Answer

I have seen problems like this before. They could be related to:

1) As @Sigur suggested, this could be due to bad configuration.

1.1) I once saw this behavior when the TeXnicCenter distribution was saved in "Programas" (in spanish) instead of "Program files". Maybe if you reinstall it where it is supposed to go you won't have more problems.

1.2) As @Speravir mentioned, you can always change this manually. Go to Build/Define Output profiles in the main menu bar. Select "LaTeX-->pdf" on the left section of the window. On the "(La)TeX" tab make sure the "Path to the (La)TeX compiler" is actually where the pdflatex.exe file is located. If using Windows it should look something like this: C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\pdflatex.exe. Of course, it is dependent on where the file is located in your computer. Make sure you are also pointing to the right bibtex.exe file in the bibtex section, as well as the makeindex.exe

2)You are using Adobe Reader X or XI and you have to change your viewer settings: For this, go to Build/Define Output profiles in the main menu bar. Select "LaTeX-->pdf" on the left section of the window. Once there, go to the "Viewer" tab and make sure the "server" says acroviewR10 (if using Adobe Reader X) for all of the entries: View Project's output, forward search and close document before running (La)TeX. Also, as in point 1), make sure the executable path is where the reader.exe is located. Once again, if using Windows, it should look something like this C:\Program Files (x86)\Adobe\Reader 10.0\Reader\AcroRd32.exe. For more on this please visit here http://tex.stackexchange.com/a/74607/27833

share|improve this answer
    
Ad 1.2: Depends, of course of the actual path. Ad 2: See e.g. tex.stackexchange.com/a/85873/9237. –  Speravir Mar 30 '13 at 4:19
    
@Mathmath, Was the information we provided useful? –  Mario S. E. Apr 3 '13 at 23:23
    
JFYI: Mathmath has not got an notification about your comment, because he/she did not participate here. You need to comment to the question. –  Speravir Apr 3 '13 at 23:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.