Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to produce a PostScript file when compiling my LaTeX file on TeXShop running on MacOS X. I already tried checking the box "Save Postscript File" under the preferences->Engine tab + selected the radio button "Tex + DVI" in the Typesetting tab, but this doesn't produce the .ps file.

Any suggestion? This is driving me crazy.

Thanks

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

With TeXShop go to typeset and enable LaTeX, dvi and ghostscript. To set this as default go to TeXShop - Preferences - Typesetting. It creates the ps and pdf file

share|improve this answer
    
Under "typeset" I only have Typeset, PlainTeX, LaTeX, BibTeX, MakeIndex, MetaPost, ConTeXt, and then PdfTex, TeX and DVI, Personal Script. Perhaps TeX and DVI? I tried this one and gives me errors about one image and its size. –  Masiar Mar 26 '13 at 12:50
    
choose LaTeX. But take care that you use only eps Images, if you have one. LaTeX can handle only ps and eps images. –  Herbert Mar 26 '13 at 12:55
    
By choosing LaTeX the compiling procedure starts, no errors shown, pdf compiled as it is supposed to be but no .ps file is produced. –  Masiar Mar 26 '13 at 12:57
    
did you enabled dvips and ghostscript? –  Herbert Mar 26 '13 at 13:23
    
No sorry, I can't find under the Typesetting tab in the preferences where I can enable "LaTeX. dvi and ghostscript". Maybe version issue? Mine is 3.11. –  Masiar Mar 26 '13 at 13:34
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.