Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I use the \Cref command of cleveref package, it doesn't apply the corresponding kerning:

Here is a minimal example:

\documentclass{scrartcl}
\usepackage[thref]{ntheorem}
\usepackage{cleveref}

\newtheorem{thm}{Teorema}

\begin{document}
\begin{thm}\label{thm}
    Teorema
\end{thm}
Te \\
\Cref{thm}
\end{document}

There is no kerning between the T and the e of Teorema.

How can I solve this? Is this a bug?

enter image description here

share|improve this question

1 Answer 1

up vote 9 down vote accepted

It's not to be considered a bug. The capitalization is obtained by applying \MakeUppercase, so detaching the first letter. Just teach cleveref what's your preferred capitalised form:

\documentclass{scrartcl}
\usepackage{ntheorem}
\usepackage{cleveref}

\newtheorem{thm}{Teorema}
\Crefname{thm}{Teorema}{Teoremi}

\begin{document}
\begin{thm}\label{thm}
    Teorema
\end{thm}
Te \\
\Cref{thm}
\end{document}

enter image description here

I'd avoid the thref option to ntheorem, as cleveref overrides it (and issues a warning about it).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.