Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem when I insert a PDF file in LaTeX:

\usepackage[final]{pdfpages}

\includepdf[pages=-]{file.pdf}

The problem is that the PDF page is not centered:

result

I've tried to place tags center, but nothing works.


Thank you for your response.

I still have the same problem.

For a good layout, I have to do this:

\includepdf[pages=1,pagecommand={},offset=-2.5cm -3cm]{file.pdf}
\includepdf[pages=2,pagecommand={},offset=2.5cm -3cm]{file.pdf}
\includepdf[pages=3,pagecommand={},offset=-2.5cm -3cm]{file.pdf}
\includepdf[pages=4,pagecommand={},offset=2.5cm -3cm]{file.pdf}
\includepdf[pages=5,pagecommand={},offset=-2.5cm -3cm]{file.pdf}

This is very annoying. I want to insert a PDF of 50 pages, I can not insert page by page ...

I tried

\begin{figure}
 \centering 
 \includepdf[pages=-]{file.pdf}
\end{figure}

But all pages of the PDF are superimposed on one page!

And with \usepackage[pdftex]{graphicx} I have an error :

! LaTeX Error: Option clash for package graphicx

Please help me!

P.S. I use a model given by my university. In this model, we find this:

%----- Dimensions -----
\setlength{\evensidemargin}{2cm}
\setlength{\oddsidemargin}{2cm}
\setlength{\textheight}{\paperheight}
\addtolength{\textheight}{-5.7cm} % 24cm
\setlength{\textwidth}{\paperwidth}
\addtolength{\textwidth}{-4cm} % 17cm
\setlength{\topmargin}{0.5cm}
\setlength{\headheight}{2cm}
\setlength{\headsep}{0.5cm}
\setlength{\voffset}{-2.54cm}
\setlength{\hoffset}{-2.54cm}
\setlength{\footskip}{1.5cm}
\setlength{\parskip}{1ex plus 0.5ex minus 0.2ex}

If I remove this:

\setlength{\voffset}{-2.54cm}
\setlength{\hoffset}{-2.54cm} 

the layout of the PDF is OK, but the rest is bad!

share|improve this question

migrated from stackoverflow.com Mar 27 '13 at 17:14

This question came from our site for professional and enthusiast programmers.

2  
Can you provide a minimal working example of your code? –  Juri Robl Mar 27 '13 at 18:15
1  
By default pages are centered and it works fine for me. So it looks as if either your pdf has curious margins or your pdfpages version has a bug. Beside this: pdfpages has a documentation which also contains a section which describes how to move the pdf around. –  Ulrike Fischer Mar 28 '13 at 7:37

5 Answers 5

I would say: put the page inside a figure environment and use the \centering command. It's action should be restricted to the figure.

\begin{figure}
 \centering 
 \includepdf[pages=-]{file.pdf}
\end{figure}

Note that a simple \includegraphics{file.pdf} should to the trick, no need for extra packages. i.e. this a working code for me:

\usepackage[pdftex]{graphicx}
\begin{document}

\begin{figure}
 \centering 
 \includegraphics{file.pdf}
\end{figure}

\end{document}

Moreover, this allows the use of additional scaling options such as \includegraphics[scale=0.50]{file.pdf}, etc.

share|improve this answer
    
Have you tried this? Moreover graphicx's \includegraphics doesn't really need the driver pdftex explicitly specified, since it's picked up by the method of compilation. –  Werner Mar 27 '13 at 19:08
    
Oops! Typo, I'll edit my post to reflect that. Otherwise, I never used pdfpage, but I used the includegraphics variant countless times :) –  Jean-Gabriel Young Mar 27 '13 at 19:34
up vote 4 down vote accepted

I found the solution :

\setboolean{@twoside}{false}

And

\includepdf[pages=-, offset=75 -75]{file.pdf}

And it works !

share|improve this answer

Try this:

\setlength{\voffset}{0cm}
\setlength{\hoffset}{0cm}

\includepdf[pages=-]{file.pdf}

\setlength{\voffset}{-2.54cm}
\setlength{\hoffset}{-2.54cm}

Then the pdf will be put in the page without the offsets of the rest of the document.

share|improve this answer

Try this. Compile it with pdflatex.

\documentclass{article}
\usepackage{pdfpages}
\begin{document}
\includepdf[pages=-]{status-lua}
\end{document}

I tested with TeX Live 2012 (just updated several days ago) and it works fine.

Note: status-lua is one (of limited number of others) accessible PDF file (in the installed TeX distribution) that I can use for a demonstration purpose.

share|improve this answer

I did it this way with package pdfpages:

\includepdf[pages=-,pagecommand={},width=\textwidth]{file.pdf}
share|improve this answer
3  
Downvoters should leave a comment explaining how the post can be improved! –  Adam Liter Mar 10 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.