TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MacBookAir and I want to draw a two-dimensional representation of a protein's secondary structure with cpssp in LaTeX. I have installed cpssp and MacTeX. I also created my ~/Library/texmf/tex/latex/cpssp. Next I have run the Python script which I called from my terminal like

python cpssp.py -s seq.fasta -u ss.fasta -w 14 -i 1.5 -t 20 -o test

I get the test.tex file but I don't know how to use LaTeX to convert those coordinates into the actual image. I have read how to create a basic LaTeX and it works but when I try with the package cpssp it does not work.

Can someone help me PLEASE. Any tip, advise or something will be appreciated.

TeX file:

share|improve this question
Welcome to TeX.sx! – Peter Jansson Mar 29 '13 at 15:35
could you please post the generated tex file here? – michal.h21 Mar 29 '13 at 16:38

You should read Section 4.2 of the documentation about the inclusion of cpssp files. I never used cpssp, but I believe something like


should do.

share|improve this answer
yes I have run it as you say the first time it complains that i do not have the cpssp.sty, then i run cpssp.in file and that generated the cpssp.sty file but then when I run I get a new error: ! Missing $ inserted. <inserted text> $ l.2 \cpsspLabel{-0.0}{pf_0111000} ? – Diana G Mar 29 '13 at 19:06
! Missing $ inserted. <inserted text> $ l.2 \cpsspLabel{-0.0}{pf_0111000} ? – Diana G Mar 29 '13 at 19:16
@DianaG Subscripts require math mode by default. Otherwise you need \textsubscript. See tex.stackexchange.com/questions/1013/… for more details – percusse Mar 29 '13 at 19:34
! Undefined control sequence. l.4 \textsubscript – Diana G Mar 29 '13 at 20:41
@VincentNivoliers It's available with fixltx2e which is good to add anyways. – percusse Mar 29 '13 at 23:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.