Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My thesis consists of these hierarchical elements:

\documentclass{report}
\begin{document}
\tableofcontents
\include{020-tex}
\end{document

where 020-tex.tex contains

\input{030-preface}
\part{First Part}
\input{040-Theory-Part-I}

\part{Second Part}
\input{040-Theory-Part-II}

\bibliographystyle{achemso.bst}
\bibliography{citations-part-i,citations-part-ii}

\input{080-sup-mat}

E.g. 040-Theory-Part-I is formatted as

\chapter*{Theoretical Framework}\addcontentsline{toc}{chapter}{Theoretical Framework}

such that the TOC lists the chapter, but no numbering is used.

In the TOC, the hierarchy levels are correctly formatted, i.e. sections are sections, chapters appear as chapters and so on. But when I view the PDF in Previews, in the sidebar which allows to "browse" the content and expand chapters, the bibliography is hierarchically under Part II, while it should be on the same level as Parts I and II. So the bibliography only appears when I expand Part II. Also the appendix appears only under Part II, while it should be on the same level as the parts and the introductions. Here's a screenshot of what I mean:

Screenshot

How can I get the red enclosed content to be on the same level as the vertical line?

share|improve this question
1  
What is your question? That's unclear. In any case, I think you should read tex.stackexchange.com/questions/246/… –  Jubobs Mar 30 '13 at 13:26
    
What exactly is your question? –  Juri Robl Mar 30 '13 at 13:26
1  
You have the \include and \input commands reversed. If you really want to profit of \include, use it for chapter files, not for the big "catch it all" file. –  egreg Mar 30 '13 at 13:47
    
While I understand your desire, strictly speaking, that is the correct layout from a traditional point of view (and from the same perspective, things like your preface are at the 'wrong' level). But you should load package bookmark and make use of the \bookmark command. Package bookmark should be on your list of always-loaded packages. –  jon Mar 30 '13 at 20:56
    
At what level should the preface be then? –  TMOTTM Mar 31 '13 at 14:18

3 Answers 3

up vote 3 down vote accepted

The correct answer is here. (Summary: use the bookmark package and \bookmarksetup{startatroot}.) I just had exactly the same problem, it worked fine. (Using the Memoir class.)

share|improve this answer
    
Welcome to TeX.SX. –  Claudio Fiandrino Mar 31 '13 at 7:40
    
I elaborated on your answer. –  TMOTTM Mar 31 '13 at 14:17

Unfortunately, all suggested options fail. The solution is to use the \bookmark package and to include these commands to indicate the end of part ii.

\bookmarksetup{startatroot}
\addtocontents{toc}{\bigskip}

As provided by @Andrew.

share|improve this answer

Ok, since it seems this is a problem with your hyperlinks in pdf.

First, make sure to load \usepackage[pdftex,pdfpagelabels,bookmarks,hyperindex,hyperfigures]{hyperref}.

Second, try using this:

\phantomsection
\addcontentsline{toc}{chapter}{Bibliography}
\bibliographystyle{achemso.bst}
\bibliography{citations-part-i,citations-part-iia}

For the appendix, try:

\appendix
\input{Papers}

In the Papers.tex file use "Paper1", "Paper2", etc. as chapters.

share|improve this answer
    
I tried, I cant fix it... –  TMOTTM Mar 30 '13 at 19:00
    
Please make sure hyperrf is the last package loaded in the preamble –  Mario S. E. Mar 30 '13 at 19:47
    
Don't use pdftex option with hyperref. It can detect the workflow. –  percusse Mar 31 '13 at 8:18
    
@MarioS.E.: It fails to compile if hyperref is loaded after bookmark. –  TMOTTM Mar 31 '13 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.