TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, I downloaded the latest version of MiKTeX and Texmaker and started using XeLaTeX. Today, I am no longer able to compile or save any .tex file. When I try to do so, a message pops up: “The file could not be saved. Please check if you have write permission.”

Do you have any idea of how I could fix this problem?

share|improve this question
With TeXmaker 4.0.1, save it as .tex extension otherwise it will pop up error. It is not saved as .tex automatically starting from new version as latex file can have any extensions .cls .sty .dtx etc.. – texenthusiast Mar 30 '13 at 22:30
Which windows? Did you install as a admin and work now as a non-admin (and the tex-file is in a system folder)? – knut Mar 30 '13 at 22:38
Ok, I saved the file as .tex and now it works fine! – ben Mar 30 '13 at 22:50
Not too localized at all – this is easily reproducible and will likely annoy many users; yet the author of Texmaker is unwilling to change it. (Voted to reopen.) – doncherry Apr 11 '13 at 5:38
@ben I added the error message I’m getting, assuming you’re getting the same one? This way, people Googling that message will hopefully find this question. – doncherry Apr 11 '13 at 16:27

Starting from TeXmaker 4.0 built on Qt5, with TeXmaker 4.0.1, save it as .tex extension otherwise it will pop up error due to Qt5 file dialog box.

It is not saved as .tex automatically starting from new version(4.0) as latex file can have many extensions like .cls .sty .dtx etc..


"It's not a bug, but the default behavior of the Qt5 file dialog" as mentioned by Author in Issue Tracker.

Unfortunately this behaviour is missing at changelog.

share|improve this answer
They could certainly use a better error message, "write permission" is totally misleading. – キキジキ Jun 29 '13 at 6:23

I have the same error and I know how to fix it. As you save the file, type: FILENAME.tex in the name box, and remember to put a dot between the file name and the format, usually you write tex. Example: PRIME NUMBERS.tex

share|improve this answer
A file name should never contain any spaces, nor special characters (like accents in vietnamese). Though most operating systems can handle it, it is very bad practice. – Johannes_B May 29 at 4:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.