Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a template I got from the internet. When I run it I get the following error.

! Fatal fontspec error: "not-pdftex"
! 
! Requires XeTeX or LuaTeX to function!

I have XeTeX and LuaTeX installed. It gives me an error at line 34 in fontspec.sty. Please help. I do not understand what is wrong. Thanks

share|improve this question
    
How exactly do you try to compile it? Please post the used command line. Simply latex myfile.txt won't work here. –  Martin Scharrer Feb 8 '11 at 18:13
4  
Have XeTeX or LuaTeX installed isn't sufficient, you must compile your document with Xe(La)TeX or Lua(La)TeX –  Matsaya Feb 8 '11 at 19:13
1  
Hmmm, I guess that error message could be rather more helpful. –  Will Robertson Feb 8 '11 at 23:07
1  
@Matsaya: Could you please post your comment as an answer so that it can be accepted. –  Caramdir Feb 9 '11 at 0:27
1  
@yO2gO Since Matsaya has answered your question, below, please consider marking the answer as ‘Accepted’ by clicking on the tickmark below their vote count. This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). –  Will Robertson Feb 9 '11 at 23:11
show 1 more comment

1 Answer 1

up vote 4 down vote accepted

Have XeTeX or LuaTeX installed isn't sufficient, you must compile your document with Xe(La)TeX or Lua(La)TeX.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.