Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a question similar to that in Cite in the caption of a graphic but not in \listoffigures?

I'm using this to create bookmarks in my generated PDFs:

\usepackage[pdftex,bookmarks=true]{hyperref}

My problem, is that I'm using inverted commas (quotation marks) in my section/subsection titles. However, my PDF bookmarks come out with backticks and two apostrophes (`` text... ''), instead of a proper pair of inverted commas. Is there a way around this?

In the question I linked to above, I see that I can specify an optional title for places like this, and if worse comes to worse, I could leave out the quotation marks. I'd really prefer to keep them, though.

share|improve this question
    
How do you create the inverted commas? Are you using a macro, an unicode character or else? –  Martin Scharrer Feb 8 '11 at 19:44
2  
Your title asks about the \cite command, but your question is about quotation marks. Is your title wrong or your question? –  Caramdir Feb 8 '11 at 20:56
    
I changed the title, to what I believe is what you ask. Please change it again if it is incorrect. –  Caramdir Feb 9 '11 at 23:31
    
Nope--that's what it should have been. Sorry! –  Brennon Bortz Feb 10 '11 at 4:06

2 Answers 2

up vote 9 down vote accepted

If, instead of the ligatures (which, I believe, is how the "double backping and double apostrophe become proper qoutation marks"-mechanism works), you use unicode characters, it seems to work as expected. Alternatively, you can use \texorpdfstring{for TeX typesetting}{for bookmarks} in your \section command.

This illustrates the two options.

\documentclass{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\usepackage[bookmarks,pdftex]{hyperref}

\begin{document}

\tableofcontents

\section{The phrases ``nudge nudge'' and “wink wink”  }

\section{The \texorpdfstring{``larch''}{"larch"}}

\end{document}
share|improve this answer
    
Using Uniode characters didn't work for me, actually. It works in the TeX output, but not in the PDF file, for some reason. The \texorpdfstring command does the trick, though. Thanks. –  Brennon Bortz Feb 9 '11 at 18:47
    
I don't know if it's viewer dependent. I'm using Adobe Reader 9 on Ubuntu. When you say it doesn't work in the pdf file, do you mean only the bookmarks sidebar, or something else? Also, one should probably be careful with copying unicode characters from a browser to an editor; all sorts of things can go wrong in that process. The two I used above are 0x201C and 0x201D (LEFT/RIGHT DOUBLE QUOTATION MARK). If you do want a pair of quotation marks where one can distinguish the left from the right, you could also try »guillemets«. They are even in the latin1 range. –  Villemoes Feb 9 '11 at 19:10
    
Sorry--I meant it doesn't work in the sidebar. Within the document, it prints just fine. –  Brennon Bortz Feb 9 '11 at 19:21

This gives different quotation marks in TeX and the bookmarks

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[bookmarks]{hyperref}

\begin{document}
\section{\texorpdfstring{My ``foo''}{My "foo"}}
bar

\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.