Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

MathTime Professional 2 doesn't work with Beamer. Did anyone encounter the same problem? Below short example:

\documentclass[10pt, xcolor=dvipsnames]{beamer}
\usepackage[utf8]{inputenc}
\usepackage{polski}
\usepackage[polish]{babel}
\usepackage[T1]{fontenc}

\usepackage{graphicx}
\usepackage{amsmath}


\usefonttheme{professionalfonts}
\usepackage[subscriptcorrection]{mtpro2}
\renewcommand{\rmdefault}{ptm}


\begin{document}

\begin{frame}{Title}
Short $x+Y$  
\end{frame}

\end{document}

I get an error message

! LaTeX Error: Command `\lll' already defined.
See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.1422 ...bol{\lll}          {\mathrel}{AMSa}{"6E}

The problem disappears when switching to the other fonts. Does anybody have a suggestion how to fix it?
It might be important to add that for \documentclass{article} MathTime Pro 2 works with minor modification the preamble.

share|improve this question
1  
The problem is that beamer automatically loads amssymb, which shouldn't be loaded with mtpro2. Try with the noamssymb option to beamer. –  egreg Apr 1 '13 at 10:31
    
Welcome to TeX.sx! –  Peter Jansson Apr 1 '13 at 10:47
    
@egreg: Thank you. After adding noamssym I had to remove \usepackage[polish]{babel} in order to get the output. Unfortunately, this switches times fonts (for text, math fonts works) into default beamer fonts. –  Robert Apr 1 '13 at 11:44
add comment

1 Answer

up vote 4 down vote accepted

The fault is in two places.

First problem: with mtpro2 one shouldn't load amssymb. This is done automatically by beamer, but can be prevented with the option noamssymb:

\documentclass[10pt,xcolor=dvipsnames,noamssymb]{beamer}

Second problem: the babel language definition file polish.ldf defines \lll for to me mysterious reasons.

Possible fix:

\documentclass[10pt,xcolor=dvipsnames,noamssymb]{beamer}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\usepackage{polski}
\usepackage[polish]{babel}

%%% fix for \lll
\let\babellll\lll
\let\lll\relax


\usefonttheme{professionalfonts}
\usepackage[subscriptcorrection]{mtpro2}

%%% fix for \lll
\let\mathlll\lll
\let\lll\babellll


\begin{document}

...

In case you need the \lll math symbol, use \mathlll.

Note that loading amsmath and graphicx is not required with beamer, that loads them automatically.

share|improve this answer
    
Thank you - it works. I used \usepackage{newtxtext} instead of \renewcommand{\rmdefault}{ptm} because time fonts don't show on a presentation. By the way: loading amsmath is require because mtpro2 disables this package. –  Robert Apr 1 '13 at 14:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.