Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working with the quoting environment but I can't figure out how to adjust the vertical space before and after it. I would like the environment to be indented on either side like it is but not have a full paragraph return before or after it.

The quoting documentation says that the space at the top of a quote is controlled by vskip. I have tried adjusting the vskip option to vskip=-8pt but it didn't do anything. I also tried adding a \noindent before the quoting environment--also didn't do anything.

Here is a minimal working example.

\documentclass[11pt, oneside]{article}% use "amsart" instead of "article" for AMSLaTeX format
% TeX will automatically convert eps --> pdf in pdflatex        
\usepackage{amssymb}

\usepackage[english]{babel}
\usepackage{blindtext}

\usepackage[parfill]{parskip}           %use line breaks instead of indentation

\usepackage{quoting}    %For inset quotes more than three lines

\title{Brief Article}
\author{The Author}
%\date{}                            % Activate to display a given date or no date

\begin{document}
\maketitle
%\section{}
%\subsection{}
\blindtext

\begin{quoting} 
This is a quote which should be indented but should not have a full
paragraph line before it or after it. In other words it should be
indented on either side but shouldn't have a full paragraph skip before.
\end{quoting}

\Blindtext

\end{document}  
share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Using the vskip=-\parskip option seems to do the trick.

\documentclass[11pt]{article}

\usepackage[english]{babel}
\usepackage{blindtext}

\usepackage[parfill]{parskip}

\usepackage[vskip=-\parskip]{quoting}

\begin{document}

\blindtext

\begin{quoting} 
This is a quote which should be indented but should not have a full
paragraph line before it or after it. In other words it should be
indented on either side but shouldn't have a full paragraph skip before.
\end{quoting}

\blindtext

\blindtext

\end{document}  

enter image description here

share|improve this answer
add comment

Looks like there is some conflict between quoting and parskip. If you comment out the \usepackage[parfill]{parskip} line, then the [vskip=0pt] option after \begin{quoting} works as expected. enter image description here

Also, this looks like a duplicate of How to modify spacing around quotation environment?

share|improve this answer
    
Actually, the quoting/parskip combo is a special case. –  lockstep Apr 2 '13 at 9:29
2  
@lockstep ah, didn't know about that, thanks for the info. –  dcmst Apr 2 '13 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.