Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to use whizzytex with emacs because of its superior speed compared to other wysiwyg options available. The only thing preventing me from doing so is that my latex documents use the minted package for source code highlighting. Minted requires latex to be run with the -shell-escape flag and I do not see how to instruct whizzytex to run latex with this flag. For example, using

%; whizzy -latex "latex -shell-escape"

does not seem to work. How can I make whizzytex work with the minted module?

share|improve this question
    
Welcome to TeX.sx! –  Peter Jansson Apr 4 '13 at 19:03

1 Answer 1

up vote 1 down vote accepted

In the whizzytex documentation it says:

For instance, a typical configuration line will be:

   %; whizzy subsection -dvi "xdvi -s 3"

It tells whizzytex to run in subsection slicing mode and use a dvi style
viewer called with the command xdvi -s 3. This is also equivalent to

   %; whizzy subsection -dvi xdvi -s 3

since Emacs removes outer double-quotes in option arguments.

I think this is why a line like

%; whizzy -latex "latex -shell-escape" -initex "latex -ini -shell-escape"

in my *.tex file cannot work. My solution now is to place a custom whizzy.sh in my working directory with the contents:

INITEX="latex -ini -shell-escape"
LATEX="latex -shell-escape"

With that file in place, I can now edit *.tex files containing minted code blocks (or other modules that require -shell-escape).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.