Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working with a Warsaw theme and smoothbars outtertheme.

I'm adding a bibliography entry at the end of the presentation that is meant to be used for a list of publications. However, these slides are not added to the circle progress bar (does this have a technical name?) from the smoothbars.

Checking the Beamer navigation circles without subsections? question I thought that adding some subsections will do the trick but that didn't work. It seems that if the frame contains a \printbibliography (and I guess any bibliography) then the frame is skipped from the progress bar. Also, I'm not sure if this has something to do with this bug.

Check the following example. The first frame appears by adding the subsection. The frames in the second subsection with the subsection in them appear also, with exception of the one with the bibliography on it.

\documentclass{beamer}

\begin{filecontents}{\jobname.bib}
@Book{test1,
  author    = {Goossens, Michel and Mittelbach,
               Frank and Samarin, Alexander},
  title     = {The LaTeX Companion},
  publisher = {Addison-Wesley},
  location  = {Reading, Mass.},
  year      = {1994},
}
\end{filecontents}

\useoutertheme[subsection=false]{smoothbars}
\usepackage{biblatex}
\bibliography{\jobname}


\begin{document}
\section{Section}
\subsection{Subsection}
\begin{frame}{test}
content...
\end{frame}

\section{Publications}
\subsection{Subsection}
\begin{frame}{in nav}
this frame is in navigation bar
\end{frame}

\subsection{References}
\begin{frame}
\nocite{*}
\printbibliography[heading=subbibliography]
\end{frame}

\subsection{Subsection}
\begin{frame}{in nav}
this frame is also in navigation bar, but the previous one isn't
\end{frame}

\end{document}

So, how can I make the slides with a bibliography on them to appear in the smoothbars/circle progress bar?

share|improve this question
    
Please add a minimal working example (MWE). –  Jubobs Apr 5 '13 at 8:33
1  
Use \printbibliography[heading=none] –  Marco Daniel Apr 5 '13 at 9:51
    
@MarcoDaniel wow... indeed an easy solution. I thought it will require some fancy workaround. –  adn Apr 5 '13 at 9:55
    
Do you need an explanation? –  Marco Daniel Apr 5 '13 at 9:58
    
That would be nice, and good for completeness (so I can mark it as an answer). I guess that the subbibliography is doing something to the heading and that is avoiding the inclusion since it is a bibliography. Once you remove the heading, then it is not recognized as one any more, and the default behavior triggers. –  adn Apr 5 '13 at 10:13

1 Answer 1

up vote 2 down vote accepted

The solution in a short form: Use

\printbibliography[heading=none]

Explanation

biblatex-part

biblatex tests which document class is loaded. The class beamer isn't valid option and so the default setting of abx@classtype is used. With these settings the option heading=subbibliography represents the following definition:

\defbibheading{subbibliography}[\refname]{%
  \subsection*{#1}}

The definition is done in the file biblatex.def. It's important to notice that the starred version of \subsection is used.

beamer-part

In beamer the structuring commands like \subsection should be placed outside the environment frame. If you put such commands inside frame you will get unwanted side effects. In your case the command \subsection* removes the entry in the smoothbar.

A simple example demonstrates this:

\documentclass{beamer}
\useoutertheme[subsection=false]{smoothbars}
\begin{document}
\section{Section}
\subsection*{Subsection}
\begin{frame}{test}
content...a
\end{frame}

\begin{frame}{test}
\subsection*{Subsection b}
content...b
\end{frame}
\end{document}

Based on the explanation above you must remove \subsection* which is done by heading=subbibliography. The simplest way is the usage of heading=none which is defined as:

\defbibheading{none}{}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.