Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For some reason, my bibliography margin has changed after a certain entry. I've attached an image of what's happening.

enter image description here

When I shuffled sources around, I found that it always happens at that particular bibliography entry. So, I checked the .bbl file and found this in the preceding entry:

\newblock 10.1007/978-3-540-92219-3_20.

Removing that fixes the problem. The thing is, I'd like for DOI and URL entries to be included in my bibliography. Should I be doing something differently?

share|improve this question
2  
I can't see any picture being attached, maybe due to your rep. However, this might be a result of a bad entry in the bib-file. The number looks like a doi and might not be enclosed in correct {}. Search your bib file for this number and check the entry –  Martin H Feb 9 '11 at 19:00
    
Hmm...that would be because I can't post images with less than 10 reputation. Either way, that did fix the problem...would you post that as an answer so that I can accept? –  Brennon Bortz Feb 9 '11 at 19:07
    
Image posted here...thanks! –  Brennon Bortz Feb 9 '11 at 19:15
    
I've embedded the image. @Martin: please post the answer, your answer should be accepted because it resolved this special case, not mine. –  Stefan Kottwitz Feb 9 '11 at 19:20

2 Answers 2

up vote 5 down vote accepted

As pointed out in the comment of the question, the error is in the bib file. The number is a doi and apparently there is a closing } missing. I figure that you are using biblatex and doi's are normally automatically typeset as verbatim/url.

Find this number in the bib file and check that the doi is enclosed in {}

share|improve this answer

The underscore _ in 10.1007/978-3-540-92219-3_20 may cause a problem because _ is the command for subscripts and requires math mode.

  • You could use \_

  • Or use \textunderscore (perhaps encoding dependent, I recommend to use T1: \usepackage[T1]{fontenc}

  • You could use the underscore package

  • you could use commands of the url package such as \path or \url. \urlstyle{same} would use the normal text font.

  • If the bibliography style supports underscores or URLs, use braces, already recommended by Martin-H in his comment.

share|improve this answer
1  
Stefan, see Martin H's comment above. It is a doi entry with missing { }, which causes the verbatim printing of this entry to fail. AFAIK it uses \url already internally. –  Martin Scharrer Feb 9 '11 at 19:18
1  
@Martin: I've seen it. I guess I let my answer here for now because it's dealing with the cause and the general solution. I asked Martin do make an answer out of his comment as well to be accepted. Thanks for taking care (and your many great tipps here). –  Stefan Kottwitz Feb 9 '11 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.