Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Normally Latex adds a hyphen if the word at the end of a line is too long, and continues the rest of the word on the next line. I'm writing my document in Dutch and when the last word on a line contains a dieresis, like the word België, Latex isn't splitting the word in two and finishes it on the same line. So the result looks kind of like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit
Lorem ipsum dolor sit amet, consectetur adipiscing België
Lorem ipsum dolor sit amet, consectetur adipiscing elit
Lorem ipsum dolor sit amet, consectetur adipiscing elit
Lorem ipsum dolor sit amet, consectetur adipiscing elit
share|improve this question
1  
Are you loading \usepackage[T1]{fontenc}? –  egreg Apr 5 '13 at 21:45
    
No, I wasn't but that did fix the problem. Thanks! You should post is as an answer so I can can accept it. –  Sled Apr 5 '13 at 21:49
add comment

marked as duplicate by mafp, Werner, Kurt, Guido, Qrrbrbirlbel Apr 5 '13 at 23:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 2 down vote accepted

If you don't load the fontenc package with the option T1, TeX will not find any hyphenation point in België, because the analysis of the word ends at the "i". The problem is that in the default OT1 encoding, accented characters are built and not precomposed; and TeX doesn't go past a built-up glyph with its hyphenation algorithm.

By loading

\usepackage[T1]{fontenc}

you tell LaTeX to use fonts where accented characters are precomposed and so are considered as single glyphs with respect to the hyphenation algorithm. Therefore T1 is recommended for all continental Europe languages, since they use plenty of accents.

If one asks

\showhyphens{België}

(with \usepackage[dutch]{babel}, of course), the answers will be

Belgi[]e

with the OT1 encoding, but

Bel-gië

with the T1 encoding. In the first case [] stands for the accent that's put over the "e". (Actually, in the second case a strange character may appear in the log file in place of "ë", but that's a different question and has nothing to do with the problem at hand.)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.