Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I know how to use biblatex and compile it with pdflatex -> bibtex -> pdflatex in TeXworks or TeXShop.

\usepackage[options]{biblatex}
\bibliography{bib-file}

\begin{document}
  \autocite{einstein01}
  \autocite{feynman47}
\end{document}

How do I start using the different biblatex styles in the CTAN contrib? I want to know how to do it in terms of:

  1. Installation
  2. Usage in the source code

Solutions for MiKTeX or TeX Live are preferred.

share|improve this question
    
This doesn't really need to be another answer but it's worth mentioning in this context: read the documentation for the style! For example, biblatex-apa needs you to put a \DeclareLanguageMapping after you load biblatex. I can't be the only person tripped up by this... –  Seamus Feb 10 '11 at 11:02
    
@Seamus: Thanks. I was looking at biblatex-science, and there was no documentation as how to use it. –  Kit Feb 10 '11 at 11:47
1  
it looks like biblatex-science is maintained by @Joseph Wright so he's the man to talk to about that! –  Seamus Feb 10 '11 at 11:51
add comment

3 Answers

up vote 13 down vote accepted

Most of the CTAN biblatex styles are part of TeXLive, so if you update all the packages using tlmgr (or TeXLive Utility on a Mac), they should be available automatically.

Generally the styles are called by

\usepackage[style=<name>]{biblatex}

or with separate bib and cite styles:

\usepackage[bibstyle=..., citestyle=...]

You can use texdoc to find the documentation for how to use the particular styles.

If in the unlikely event that the style you want isn't part of TeXLive, you can install extra biblatex packages into the latex folder of your local texmf folder just like you would install any other latex package. It's helpful to keep them in separate folders (or even in one biblatex folder within the latex folder.)

If you put the documentation into a folder corresponding to the style name in the local texmf/doc/ folder it will also be found with texdoc.

share|improve this answer
add comment

As Alan says, many of the contributed styles are available in TeX Live and MiKTeX. If not, the style files themselves (.bbx and .cbx) need to be installed like any other locally-installed files. Taking the example of my own biblatex-chem bundle, I'd need to create a local installation folder which is operating system dependent:

  • ~/texmf/tex/latex/biblatex-chem on Linux (~ = your home folder)
  • ~/Library/texmf/tex/latex/biblatex-chem on Mac OS X (~ = your home folder)
  • <USERPROFILE>\texmf\tex\latex\biblatex-chem on Windows (<USERPROFILE> = your home folder)

You might already find the texmf folder and some subfolders, or you might have to create it. You'd then put all of the .bbx and /cbx files from CTAN in this new folder. If you are using MiKTeX on Windows, you then need to make sure it has <USERPROFILE>\texmf set as a 'root' in the MiKTeX Options.

It is not necessary to subdivide the biblatex-chem folder into folders bbx and cbx, although you can if you like (biblatex itself does this).

Optionally, you might install the documentation files (PDFs, .tex and .bib sources) in texmf/doc/latex/biblatex-chem. However, that's only necessary if you want texdoc biblatex-chem to work.

For other biblatex styles, the same applies and all you need to do is modify the folder name.

share|improve this answer
    
on a Linux machine it can also be $TEXMFLOCAL instead of $TEXMFHOME –  Herbert Feb 10 '11 at 8:56
    
@Herbert. My take is usually that people asking for instructions on installation won't have moved stuff about. So I go with the standard settings exclusively. (Most newer users probably won't know what $TEXMFHOME is!) –  Joseph Wright Feb 10 '11 at 8:58
    
@Joseph Just so I get this clear, there's no need to create either a biblatex folder or separate cbx, bbx, lbx folders; you can just install the folder for the style into your texmf/tex/latex folder just like you would install a regular package? (Then I should simplify the second part of my answer.) –  Alan Munn Feb 10 '11 at 13:20
    
@Alan: beyond tex/latex, organisation is 'up to you'. Using a per-package folder is the convention, but is not enforced by the texhash system. So you install bbx and cbx files in exactly the same way as a standard package. –  Joseph Wright Feb 10 '11 at 14:00
    
Ok. I'll adjust my answer. (I think I was assuming biblatex was sensitive to folder structure like the bib/bst structure that is required (and enforced.)) –  Alan Munn Feb 10 '11 at 14:06
show 2 more comments

If you want to use the full power of biblatex then you should also install the program biber which can be done by the TeXLive package manager (and MikTeX's as well). It can also be installed via http://biblatex-biber.sourceforge.net/.

Running biber instead of bibtex with (Any)tex->biber->(Any)tex gives you full UTF support for the bibliography, which isn't possible with bibtex or bibtex8.

Using biber needs a

\usepackage[backend=biber,style=...]{biblatex}

You should also consider, that pdflatex can handle only a subset of UTF-8. Only XeTeX or LuaTeX have full UTF support.

share|improve this answer
2  
You can install Biber using the TLContrib repository for TeX Live 2010. See tlcontrib.metatex.org (which has the recent update to do better mapping of UTF-8 to LaTeX characters for pdfLaTeX). –  Joseph Wright Feb 10 '11 at 10:58
    
that doesn't solve the problem with the limited UTF-8 support of pdftex. If the bibliography has an UTF8 character for which TeX has no command sequence then you are lost ... –  Herbert Feb 10 '11 at 11:11
    
I did say 'better': I was thinking of cases where LaTeX can handle things. It's still more convenient to be able to have a UTF-8 bibliography file. (This is what I do, where the only accents I need to worry about are \", \', etc., which LaTeX can handle but which I'd rather not hard-code into my database.) You are of course correct that for full UTF-8 abilities you need a UTF-8 engine. –  Joseph Wright Feb 10 '11 at 11:33
    
@Joseph: it is not only the missing full UTF-8 support in pdftex, it is also a problem with the characters which are not supported by inputenc. And a LaTeX user didn't really know that the biber option bblsafechars helps here. The documentation of biber is a really short one. –  Herbert Feb 10 '11 at 11:48
    
MiKTeX does also include biber: miktex.org/packages/miktex-biber-bin –  matth Jul 18 '12 at 8:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.