Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I wrote the following reference in my .bib file:

@ARTICLE{Auvinet11,
  author = {E. Auvinet and F. Multon and A. St-Arnaud and J. Rousseau and J. Meunier},
  title = {Fall Detection With Multiple Cameras: An Occlusion-Resistant Method \\
    Based on 3-D Silhouette Vertical Distribution},
  journal = {Information Technology in Biomedicine},
  year = {2011},
  volume = {15},
  pages = {290-300},
}

Because of this reference, LaTeX gives me a badbox warning

underful hbox (badness 1158)

and the output .dvi file is like the following:

enter image description here

How can I solve this problem?

Postscript

Taking David Carlisle and Svend Tveskaeg's suggestion, I added \hyphenation{bio-med-i-cine} to my preamble. The result becomes:

enter image description here

This is better, but the author part is still not correct.

One more question, how does Latex decide to break the sentence? Does it break according to the correct hyphenation points of the word?

share|improve this question
    
are you using the IEEEtran class? –  Mario S. E. Apr 8 '13 at 14:51
    
@MarioS.E.yes, it's IEEEtran class –  FihopZz Apr 8 '13 at 15:33
    
and what's the \bibliographystyle you are using? –  Mario S. E. Apr 8 '13 at 15:44
    
@MarioS.E. \bibliographystyle{IEEEtran} –  FihopZz Apr 8 '13 at 15:45
add comment

2 Answers

up vote 7 down vote accepted

By default using the US English patterns, TeX doesn't hyphenate the word "Biomedicine"; you could add something like

\hyphenation{Bio-medi-cine}

to your preamble.

share|improve this answer
    
According the Merriam-Webster, it should be \hyphenation{Bio-med-i-cine}. –  Svend Tveskæg Apr 8 '13 at 15:09
    
Taking David Carlisle and Svend Tveskaeg's suggestion, I add \hyphenation{bio-med-i-cine} to my preamble. The result becomes: !enter image description here The author part is still not correct. One more question, how does Latex decide to break the sentence? Does it break according to the correct hyphenation points of the word? –  FihopZz Apr 8 '13 at 21:32
    
Hi Carlisle, There's still a problem after adding the hyphenation. I've described the problem in my answer to the question. Please take a look at it. –  FihopZz Apr 8 '13 at 21:33
    
@FihopZz I don't see any problem in the posted image. –  David Carlisle Apr 8 '13 at 21:57
add comment

Taking into consideration what @David Carlisle just posted and what @Svend Tveskaeg pointed out, you have a few moves:

1) Try:

\hyphenation{bio-med-i-cine}

in your preamble. This will set the correct hyphenation points and hopefully will break the sentence in the right place.

2) Since you are using the IEEEtran class, you could also use one of this bibliography styles. Please note that not all of them are IEEE compliant, and you'll have to check this based on IEEE bst how to Documentation

\bibliographystyle{IEEEtran} % The standard IEEEtran BibTeX style file. For use with IEEE work.

\bibliographystyle{IEEEtranS} % A version of IEEEtran.bst that sorts the entries. Some IEEE conferences/publications may use/allow sorted bibliographies.

\bibliographystyle{IEEEtranSA} % Like IEEEtranS.bst, but with alphanumeric citation tags like alpha.bst. Not for normal IEEE use.

\bibliographystyle{IEEEtranN} % Like IEEEtran.bst, but based on plainnat.bst and is compatible with Patrick W. Daly's natbib package. Not for normal IEEE use.

\bibliographystyle{IEEEtranSN} % Sorting version of IEEEtranN.bst. Not for normal IEEE use

Now, if you don't need your work to be IEEE compliant, you can always try not using the default (and IEEE mandatory) line instead of the authors' names. This is done by specifing a new bibliography entry in your .bib file:

@IEEEtranBSTCTL{IEEEexample:BSTcontrol,
  CTLdash_repeated_names = "no"
}

and then using \bstctlcite{IEEEexample:BSTcontrol} in your code.

However, if you have to stick to the IEEEtran class and IEEEtran.bst, I suggest you go completely with option 1). If not, try using natbib and one of the bibliography styles I provided. natbib is very powerful and most likely will handle this with no problem.

share|improve this answer
    
Hi Mario, There's still a problem after adding the hyphenation. I've described the problem in my answer to the question. Please take a look at it. –  FihopZz Apr 8 '13 at 21:34
    
What author part? Have you seen my suggestion on how to avoid the line and get the authors' name instead? –  Mario S. E. Apr 8 '13 at 21:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.