Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using a beamer theme I currently write I face a problem with text that moves - this text move is undesired. Here's a simple example to reproduce the effect using a standard beamer theme:

\documentclass[t]{beamer}
\usepackage{blindtext}
\usetheme{Boadilla}
\begin{document}

\begin{frame}{Title 1}
\blindtext
\end{frame}

\begin{frame}[plain]{Title 2}
\blindtext
\end{frame}

\end{document}

On page 2 which is set without footline (option plain) the text (body) moves upwards (I use TeX Live 2012). Two questions:

  1. What's causing this effect? I searched the various style files but couldn't determine the root of the problem.
  2. How can I avoid the text move? On page 2 I would just like the footline to disappear while all the rest should stay in the same position compared to page 1.

EDIT (12/04/2013)

I've found out why the text of the body moves: In beamerbaseframe.sty the environment beamer@frameslide gets defined. Amongst lots of other commands, there's a line

\ifbeamer@plainframe\nointerlineskip\fi%

which seems to cause the text move. When re-defining the environment and commenting out that line, the text of the body stays in the same place. In other words, the extra \nointerlineskip on plain frames causes this behaviour. It seems on non-plain frames there's automatically interline spacing inserted which makes standard and plain frames incompatible when using top alignment. I am still not sure how to best solve this problem...

share|improve this question
1  
welcome to TeX.SE! –  Nils L Apr 10 '13 at 19:42
1  
Even though not visible, I guess Boadilla has a nonzero height headline theme in action. When you use plain also the headline is discarded. So best is temporarily disable the footline theme only instead of the whole theme of the frame. –  percusse Apr 10 '13 at 21:39
    
@Nils: Thanks :-) –  Thomson Apr 11 '13 at 13:38
    
@percusse: You can easily reproduce the problem also using the default theme (which has an empty headline) and defining your own footline. The headheight will be 0.0pt but nevertheless if you use the option plain the text of the frame body will move upwards. –  Thomson Apr 11 '13 at 13:41
add comment

1 Answer

I have no explanation but maybe a fix. Do not use plain as option but rather redefine the footer to be empty. If you want the infolinesback (That's how this part is called I guess) have a look at the corresponding beamer theme files.

\documentclass[t]{beamer}
\usepackage{blindtext}
\usetheme{Boadilla}
\begin{document}

\begin{frame}{Title 1}
\blindtext
\end{frame}

\setbeamertemplate{footline}{}

\begin{frame}{Title 2}
\blindtext
\end{frame}

\end{document}
share|improve this answer
    
This solution works although it's not ideal for two reasons: 1) I need explicit code to disable and re-enable the footline and 2) it is what I expected the plain option to do in the first place. I would certainly like to (better) understand the problem before choosing such a solution. Even with themes that have no headline the text of the frame body starts to move when frame option plain is selected. It could have something to do with the beamer@entrycode and beamer@exitcode but I am not sure. Those macros get redefined with option plain. –  Thomson Apr 11 '13 at 13:49
1  
See possible explanation in the edited part of my original question. –  Thomson Apr 12 '13 at 13:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.