Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following the instructions here I tried to install the Vollkorn font. Now, after some fiddling (see the comments on the above linked blog post) I managed to get the font to work, but there are some problems. First, it looks kind of jagged. Vollkorn looks bitmappy

Second, loading the microtype package seems to break it. I get this error:

LaTeX Font Warning: Font shape `LY1/vkn/bx/n' in size <10> not available
(Font)              Font shape `LY1/vkn/b/n' tried instead on input line 17.

[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}
! pdfTeX error (font expansion): auto expansion is only possible with scalable fonts.

                   \endgroup \set@typeset@protect 
l.22 \end{document}

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on test.log.

Also, running pdffonts test.pdf gets me some odd results:

name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
[none]                               Type 3            yes no  no       4  0
[none]                               Type 3            yes no  no       5  0
[none]                               Type 3            yes no  no       6  0

Something isn't working, but I'm not quite sure what. Any pointers on how to diagnose the problem?

Minimal example (although you probably could have worked this out yourself)

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage{microtype}
\usepackage{vollkorn}
\usepackage{lipsum}
\begin{document}
\textbf{Bold} \textit{Italic}
\lipsum[1]
\end{document}

Log with Microtype | Log without Microtype

share|improve this question
2  
Make a small complete example (with microtype) that demonstrates the problem. Then remove microtype and compile with pdflatex. Show the complete example and the log-file of compilation without microtype. –  Ulrike Fischer Feb 11 '11 at 8:45
    
Did you make a map-file for your vollkorn fonts? If yes: what is its content and is this content in /var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map? –  Ulrike Fischer Feb 11 '11 at 10:34
    
I think part of the problem is that the ubuntu package version of texlive does all kinds of weird stuff like have all these files be generated by a bunch of other files in a different directory, so keeping track of all this stuff is tricky... I don't the pdftex.map has lines for Vollkorn in it, but there is a .map file for Vollkorn in the dvips folder –  Seamus Feb 11 '11 at 10:54
    
@Seamus I guess you need a .map in ~/texmf/fonts/map (and update maps then). –  brownian Feb 11 '11 at 11:19
1  
@Seamus: If you want your problem to be solved fast you should try to be more precise. Don't write "there is a .map in the dvips folder" but "there is ExactName.map in ExactPath". Apart from this: Try on the command line updmap-sys --enable Map=mapfile. Check if the command updated the pdftex.map and if it now contains your font entries. –  Ulrike Fischer Feb 11 '11 at 11:57

1 Answer 1

up vote 2 down vote accepted

Once I'd got the right lines added to the pdftex.map file, the bitmappiness went away and pdffonts gave the right answers.

The "right lines" in this case were all the lines for the relevant font "Vollkorn" which I copied from the dvips.map file. That is, I searched the map file for lines that had "Vollkorn" in them, and copied those into the pdftex.map file.

[In fact, I think for this particular font, it had its own map file /texmf-var/fonts/map/dvips/friedrichalthausen/friedrichalthausen.map but in general, the procedure would be as above...]

share|improve this answer
1  
Erm, and what are "the right lines"? –  Hendrik Vogt Mar 1 '11 at 13:23
    
Good point. I've added some detail, but like I've said elsewhere, fonts are still a "Dark Art" to me... –  Seamus Mar 1 '11 at 13:40
1  
You should not change pdftex.map manually. It will be overwritten if you (or the package manager when installing a font) calls updmap or updmap-sys (depending on your texsystem and the location of pdftex.map). Map files are enabled with updmap-sys --enable Map=mapfile or updmap --enable Map=mapfile –  Ulrike Fischer Mar 1 '11 at 13:50
    
I should have answered this question at the time. I can't actually remember what I did now. I only answered it to get it off the unanswered list. Perhaps it's best if I just delete the question. (Unless someone wants to provide a good answer... –  Seamus Mar 1 '11 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.