Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since I couldn't use the first-setup.bat script behind my authentication based, HTTP only, corporate proxy, I went for cygwin.

I installed the version 20120628-1 of a package named texlive-collection-context and tried it.

$ context test.tex

mtxrun          | forcing cache reload
resolvers       | resolving | unknown configuration file '/home/xxx/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/bin/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/bin/share/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/bin/share/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/bin/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/bin/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/share/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/share/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/usr/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/usr/share/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/usr/share/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/usr/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '//usr/usr/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/./texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/./share/texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/./share/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/./texmf-site/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file '/./texmf/web2c/texmfcnf.lua'
resolvers       | resolving |
resolvers       | resolving | warning: no lua configuration files found
resolvers       | resolving | no texmf paths are defined (using TEXMF)
resolvers       | resolving |
mtxrun          | the resolver databases are not present or outdated
resolvers       | resolving | using suffix based filetype 'lua'
resolvers       | resolving | remembering file 'mtx-context.lua'
resolvers       | resolving | using suffix based filetype 'lua'
resolvers       | resolving | remembering file 'mtx-contexts.lua'
resolvers       | resolving | remembered file 'mtx-context.lua'
resolvers       | resolving | using suffix based filetype 'lua'
resolvers       | resolving | remembering file 'mtx-t-context.lua'
resolvers       | resolving | using suffix based filetype 'lua'
resolvers       | resolving | remembering file 'mtx-t-contexts.lua'
resolvers       | resolving | remembered file 'mtx-t-context.lua'
resolvers       | resolving | using suffix based filetype 'lua'
resolvers       | resolving | remembering file 'context.lua'
mtxrun          | unknown script 'context.lua' or 'mtx-context.lua'

However, texmfcnf.lua file is available on the system :

$ ls -l /usr/share/texmf/web2c/texmfcnf.lua
-rw-r--r-- 1 xxx Domain Users 8356  6 août   2012 /usr/share/texmf/web2c/texmfcnf.lua

I don't understand why the script try to access //usr instead of /usr. In the source of mtxrun, I got stuck in function identify_configuration_files() line 12711:

local realname = resolvers.resolve(filename)

which transform /selfautodir:/share/texmf/web2c/texmfcnf.lua into //usr/share/texmf/web2c/texmfcnf.lua

And about the last error, it seems that the requested file exists too:

$ ls -l /usr/share/texmf-dist/scripts/context/lua/mtx-context.lua
-rw-r--r-- 1 xxx Domain Users 65606  2 juil.  2012 /usr/share/texmf-dist/scripts/context/lua/mtx-context.lua

edit1

A symbolic link from ~/texmf to /usr/share/texmf solve most issues !

lrwxrwxrwx  1 xxx Domain Users    16 12 avr.  16:28 texmf -> /usr/share/texmf
lrwxrwxrwx  1 xxx Domain Users    22 12 avr.  16:36 texmf-dist -> /usr/share/texmf-dist/
lrwxrwxrwx  1 xxx Domain Users    22 12 avr.  16:36 texmf-site -> /usr/share/texmf-site/

$ context test.tex just hangs (time to timeout each network access) and exit with a new, and very long, error log (even after mtxrun --generate):

[snip]
resolvers       | resolving | using given filetype 'tex'
resolvers       | expansions | using caches scan of path '/home/a865111/texmf/tex/generic', branch '/home/xxx/texmf/tex/generic'
resolvers       | resolving | remembering file '/home/xxx/.texlive2012/texmf-var/luatex-cache/context/74fde8c492a75a0a124aaeb6119048d0/formats/texmf-dist/tex/context/base/context.lus'
resolvers       | formats | unknown stub specification: /home/xxx/.texlive2012/texmf-var/luatex-cache/context/74fde8c492a75a0a124aaeb6119048d0/formats/texmf-dist/tex/context/base/context.lus
mtx-context     | error, no format found with name: cont-en, aborting
system          | total runtime: 15.453

o_O

edit2

As in this post : TeXLive 2011 ConTeXt problem texexec test.tex seems to work now

share|improve this question
1  
Welcome to TeX.SX. –  Claudio Fiandrino Apr 12 '13 at 13:25
    
According to the UNC paths section of the Cygwin User's Guide, // prefixes have a special meaning in Cygwin (while in regular UNIX, they are equivalent to a single slash). This could explain the difference you are seeing, but it doesn't explain the behaviour of texmfcnf.lua. –  Charles Stewart Apr 12 '13 at 14:12
    
What happens if you copy the texmfcnf.lua file into your home directory? –  Charles Stewart Apr 12 '13 at 14:38
    
OT: Did you try using the method described on the context wiki for setting the proxy settings for first-setup.bat. –  Aditya Apr 12 '13 at 17:09
    
Take a look at the paths David Carlisle reports on chat: chat.stackexchange.com/transcript/message/8950308#8950308 - you might be better off trying to figure out what is going on on chat rather than here. –  Charles Stewart Apr 12 '13 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.