Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using apacite package and can't get my bibliography to compile. I was using another style until now, which was working, but I need APA. Does it matter how I created the .bib file (I imported references from Google Scholar, and there are different citation styles there, I didn't always select APA), or will the display of the references be handled by the package no matter how the bib was generated? Some errors I get are "Case mismatch errors between keys" and "I couldn't open style file apastyle.bst". Partial example below.

\documentclass[12pt,twoside,a4paper]{book} 
\usepackage[english]{babel}
\usepackage{apacite}
...
\bibliographystyle{apastyle}
\bibliography{Bibliography}
share|improve this question
    
Do you have apastyle.bst installed (It is not installed in my TexLive 2012 system) are you sure it should not be \bibliographystyle{apacite} ? (I have an apacite.bst installed. –  David Carlisle Apr 13 '13 at 18:23
    
As David Carlisle says you should use \bibliographystyle{apacite}. See the package documentation –  Andrew Swann Apr 13 '13 at 19:19
    
I changed apastyle to apacite, but still seeing the case mismatch errors. The other error message disappeared. I checked in TeXLive, it shows I have apacite installed, but how do I check for apastyle.bst? Searching for apastyle didn't show anything. –  Bini Apr 13 '13 at 19:32
    
The case mismatch actually refers to an entry that I already deleted from the database. I ran pdflatex, then twice Bibtex, and it keeps giving the same message. The citation key is nowhere in the text anymore. –  Bini Apr 13 '13 at 20:26
    
Problem solved, was my mistake. Apparently, the keys are case sensitive and I had forgotten to fix those in a chapter I was importing in the main body, thus the "case mismatch" after I thought I deleted the entries. –  Bini Apr 14 '13 at 4:41
add comment

1 Answer

The citation keys are case sensitive. Fixing them in all section of the document removed the error message. The 'I couldn't open file..' was like David Carlisle and Andrew Swann said due to using apastyle instead of apacite.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.