Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have an issue with the double quote in my quotation.

Using "OpenGL....." results in ÖpenGL... even with \"OpenGL... the result is the same.

Using \verb results in double quotes in a wrong font type (at least it looks out of place).

\begin{quotation}
"OpenGL (Open Graphics Library) ist eine Spezifikation für eine plattform-
und programmiersprachenunabhängige Programmierschnittstelle zur
Entwicklung von 2D- und 3D-Computergrafik."
\end{quotation}
share|improve this question
    
\shorthandoff{"} could help, see the babel documentation for this command. Though it's recommendable to quote in another way, as the answers show. –  Stefan Kottwitz Feb 11 '11 at 18:25
3  
Just a comment: usually in TeX, putting a backslash makes things "worse" and not "better", in that it does not escape characters to become less special, but more. It's not like \" in, say, Linux filenames, which is a literal quotation character rather than a string delimiter. –  Ryan Reich Feb 11 '11 at 19:32

2 Answers 2

up vote 18 down vote accepted

Do not use " for quoting, use `` and '' (English quotes) or "` and "' (German quotes, needs babel, see below) instead:

\begin{quotation}
"`OpenGL (Open Graphics Library) ist eine Spezifikation für eine plattform-
und programmiersprachenunabhängige Programmierschnittstelle zur
Entwicklung von 2D- und 3D-Computergrafik."'
\end{quotation}

The babel package with the german/ngerman option does the "O -> Ö translation. This is to for (old) systems which do not have the Umlauts.

share|improve this answer
    
Yeah, thanks. I am using \usepackage[ngerman]{babel}, hope that is correct?! –  WarrenFaith Feb 11 '11 at 18:13
6  
This, or skip that and take a look at the csquotes package. (Background for the OP: "+character is special when support for german is loaded, so that "a yields ä etc. If you don't like csquotes, "` and "' will yield proper quotes.) –  Ulrich Schwarz Feb 11 '11 at 18:14
    
@Warren: This is correct (for the new orthography). It just changed the meaning of ". –  Martin Scharrer Feb 11 '11 at 18:21
    
@Ulrich: Yes, I should have mentioned csquotes, but I tried not to give too much information. –  Martin Scharrer Feb 11 '11 at 18:21

The csquotes package has been mentioned several times, so I decided to make a small example:

\documentclass{article}

\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}

\SetBlockEnvironment{quotation}

\begin{document}

\begin{displayquote}
  \enquote{%
    OpenGL (Open Graphics Library) ist eine Spezifikation für eine plattform- und
    programmiersprachenunabhängige Programmierschnittstelle zur Entwicklung von
    2D- und 3D-Computergrafik.%
  }%
\end{displayquote}

\end{document}

Note that display quotes are usually set without quotation marks.

share|improve this answer
1  
And now my beginner question: why using the % behind the curly brackets and the text? –  WarrenFaith Feb 11 '11 at 21:03
3  
@Warren: a linebreak counts as a space (unless "hidden" in a oomment), and here this would result in a space, for example, after the opening quote before the word OpenGL. –  Ulrich Schwarz Feb 11 '11 at 21:38
    
@Ulrich: thanks, I just tested it and I saw the spaces... didn't know that. –  WarrenFaith Feb 11 '11 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.