Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Here's my minimal example:

\documentclass{memoir}
\usepackage{minitoc}
\usepackage{lipsum}
\doparttoc
\begin{document}
\tableofcontents
\part{The Only Part}
\parttoc
\chapter{The Only Chapter}
\section{The Only Section}
\lipsum[1]
\end{document}

Everything appears to render fine, except that the parttoc entry for the chapter has no page number (while the entry for the section does).

If I use the report class, with no other changes, the chapter page number reappears. The main toc appears normal in both cases.

I am considering solving this by turning off all page numbers in the parttoc, but I'd like the option of keeping them, with the chapter page numbers too.


I have successfully tested, and accepted, @Stefan Kottwitz' solution with minitoc v60 and memoir v3.6g.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Normally, \ptcpagenumbers should fix it. But there are known incompatibilities between certain versions of minitoc and memoir, though the minitoc author tries to keep that minimal.

I could reproduce your problem with minitoc v60 and memoir v3.6d. I read in minitoc.sty which internal macro is used. I defined such that it worked. This is the fix, just add it to your preamble:

\makeatletter
\let\ptc@pgno\null
\makeatother

As known, such internal macros might change in future versions.

share|improve this answer
    
Thank you. Your valuable warning on the last line is duly noted (:-) –  Brent.Longborough Feb 12 '11 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.