Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In a document I need to switch to landcape mode and insert some pictures. The pictures are the same size in all following pages and inserted in the same way. In the first page of landcape mode the pictures are shifted cca 2 cm upwards (towards the longer side of the page) when compared with the pictures in all following pages. I want the pictures to be aligned in the same way in all pages. What's wrong? Thank for your suggestions.

There is no formatting in the code, just plain insertion of pictures..

\begin{landscape}
%%%
\begin{figure}[!h]
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlCRSopt.png}
\end{subfigure}
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlCRSreg.png}
\end{subfigure}

\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlCRSsec.png}
\end{subfigure}
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlCRS6.png}
\end{subfigure}
\end{figure}

\begin{figure}[!h]
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlNCSopt.png}
\end{subfigure}
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlNCSreg.png}
\end{subfigure}

\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlNCSsec.png}
\end{subfigure}
\begin{subfigure}[b]{11.6cm}
\centering
 \includegraphics[width = 11.6cm]{pic/app2_broadlNCS6.png}
\end{subfigure}
\end{figure}

...

share|improve this question
    
Your example can not be run so we can not see the shift you mean please always post complete documents. (You can replace \includegraphics by \rule{3cm}{1cm} for whatever size shows the problem to make the file self contained). However I would guess that the problem is your use of the [!h] option (you should never use h without using p and probably t, it leaves latex so few options. Remove all the [!h] and add \clearpage between each one. –  David Carlisle Apr 17 '13 at 8:48
    
Perfect! As you said, the problem was the [!h]. Thank you. –  user28050 Apr 17 '13 at 8:54

1 Answer 1

The problem is your use of the [!h] option (you should never use h without using p and probably t, it leaves LaTeX so few options Using the optional argument to figure generally restricts the places where the float is allowed. Remove all the [!h] and add \clearpage between each one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.