TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using MiKTex 2.9.4196 with TeXnicCenter 2.0 beta on Windows 7. As I have to compile very large tikzpictures I use tikz externalize. Nevertheless some tikzpicture still produce an error.

! TeX capacity exceeded, sorry [pool size=3147270].

I already did increase the main memory, but I couldn't find out how to change the pool-size.

share|improve this question
    
Related Question: Compiling a 870 mb latex file. – Peter Grill Oct 30 '13 at 2:12
up vote 9 down vote accepted

You can use the command line option:

pdflatex --pool-size=5000000 ....

You can also change the pool size e.g. for pdflatex permanantly: Run on the command line

initexmf --edit-config-file pdflatex

This will open a local pdflatex.ini in the editor. Add

pool_size=4250000

Then save the file.

It shouldn't be necessary to rebuild the format for this value, but for other parameters it is sometimes needed.

You can find the default values in the manual in Chapter 10. TEXMF Run-Time Parameters.

share|improve this answer
    
To rebuilt the file, it seems you have to type initexmf --dump=pdflatex. – Jamie Vicary Jan 22 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.