Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Do these programs support forward and inverse search (with built in PDF viewer or YAP) for files that have a root file which has many chapter files used with \include? I have tried this with no success. I have -synctex=--1 directive included and I have set the root file as the "Master Document". I am currently using Windows 7, with latest versions of TeXstudio and Texmaker. My TeX program is Miktex 2.9. The main attraction of these programs for me is that I can use them on Windows and Mac. My main tex editor on windows is Winedt and I am very happy with it.

share|improve this question
1  
I use TeXstudio on Linux and it works well, but the argument to pass is -synctex=1. –  Sigur Apr 21 '13 at 1:20
    
-synctex=-1 would also work, I think. –  Torbjørn T. Apr 21 '13 at 6:53
    
related: tex.stackexchange.com/questions/37327/… –  matth Apr 21 '13 at 7:23
    
You should set the your main file as Options -> Masterdocument. Specifically in TeXstudio, you can use Ctrl+LeftClick on the source code and in the internal PDF viewer for forwarwd/inverse search. Forward/inverse search also works for Texmaker, but I don't know the details there. –  Tim Hoffmann Apr 21 '13 at 8:47
1  
The difference between -synctex=1 and -synctex=-1 is that the latter won't gzip the .synctex file. But -synctex=--1 fails silently. –  egreg Apr 21 '13 at 11:15
add comment

2 Answers 2

If you are using file names with blanks, the problem is with TeXstudio and TeXmaker, whose command line is something like (supposing your file is C cè.tex)

pdflatex.exe -synctex=1 -interaction=nonstopmode C cè.tex

while the corresponding command line in WinEdt is

pdflatex.exe -synctex=-1 -interaction=errorstopmode "C cè.tex"

so you would have to change TeXstudio command line (in Options -> Configure -> commands) to

pdflatex.exe -synctex=1 -interaction=nonstopmode "%.tex"
share|improve this answer
add comment

I´ve tried all solutions to this problem found in several forums and none worked. Finally I found out that the problem, in my case, was simply that my file had spaces in its name, which seems to be a problem for synctex. Hope it helps in your case as well.

share|improve this answer
1  
Welcome to TeX.sx! TeX.SX starter guide –  Peter Jansson May 8 '13 at 13:51
    
synctex does not work with file names which contain spaces or filénàmeswith accentuated characters. Best practices of Naming LaTeX files –  texenthusiast May 8 '13 at 16:54
    
@texenthusiast the problem with synctex and file names with blanks has been solved time ago –  karlkoeller May 8 '13 at 17:50
    
@karlkoeller BTW when was it solved ? which release of TeXLive distro year onwards ? Any documentation on it or release notes/changelog ? –  texenthusiast Feb 21 at 4:01
    
@texenthusiast Unfortunately I can't remember when. And I've not been able to find anything in changelogs... –  karlkoeller Feb 21 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.