Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My document type should be report and I need to start my abstract at the top of the page. But with the below code, the abstract is centered on the page. What do I need to do? (I cannot change the type of document.)

\documentclass[12pt,a4paper,oneside]{report}
\begin{document}
\begin{abstract}
.................
\end{abstract}
\end{document}
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

With the titlepage class option (which is the default in report), the start of the abstract environment contains \null\vfil which (together with a corresponding \vfil\null at the end) vertically centers the environment. Remove \null\vfil, e.g. with the help of the etoolbox package.

\documentclass{report}

\usepackage{etoolbox}
\patchcmd{\abstract}{\null\vfil}{}{}{}

\usepackage{lipsum}

\begin{document}

\begin{abstract}
\lipsum[1]
\end{abstract}

\end{document}
share|improve this answer
    
It worked.....thank u very much.. –  Emalka Apr 24 '13 at 10:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.